Question

Voice Control Won't Play Station

  • 15 February 2021
  • 10 replies
  • 76 views

When I attempt to play this station through Alexa, I receive an error message.  I have to open the Sonos Desktop or Mobile App.  How can this be fixed?


10 replies

Userlevel 4
Badge +7

Hi @chucklap, welcome to the Sonos Community!

Do you only experience the issue with this specific station? Are you able to start other stations via Alexa with no issue?

How does Alexa respond when you ask her to start that station? What is the specific error message she replies with?

The error message is in the screen shot.  Sonos blames Amazon and Amazon says it is a Sonos issue.  I am able to play both stations via Alexa on an Echo speaker.

When I attempt to play this station through Alexa, I receive an error message. I have to open the Sonos Desktop or Mobile App. 

Userlevel 4
Badge +7

Understood @chucklap, I can see the error message in the screenshot. You mentioned that this happens when you try to use Alexa to start playback - how does Alexa respond to the command?

Could you also specify the exact command that you are giving to Alexa?

Command: “Alexa, play WBSM.”

 

Alexa Response: “Now playing AM 1420, WBSM.”  Station audio does not play.

Userlevel 4
Badge +7

Got it, thanks for providing that information.

Looks like there’s a specific WBSM skill for Alexa - mind opening the Alexa app > More > Skills & Games, do a search for WBSM, and then disable and re-enable the Skill?

Is there any change after doing so? It may also be worth disabling and re-enabling the Sonos Skill, following the same steps as above.

Hi.  I tried both and there is no change.  Since this station and co-owned WFHN play on Echo speakers, could this be a Sonos engineering/tech issue?

Userlevel 4
Badge +7

Thanks for trying that - doesn’t look like the WBSM skill is available in my region so I’m not able to test it myself unfortunately.

Are you giving the voice command to a Sonos speaker with Alexa installed, or to one of the Echo speakers? If you give the command to an Echo speaker, but target the Bedroom e.g. “Alexa, play WBSM in the Bedroom" is there any change?

If you have Alexa installed on a Sonos speaker, could you also check the Voice Activity in the Alexa app (More > Activity > Voice Activity)? Are you able to see any recent commands relating to WBSM given to the Sonos speaker?

It may also be worth getting in touch with the Support Team via live chat or phone, as they have more tools available for troubleshooting.

The wake word for the Amazon Echo is “ECHO.”  The Sonos responds to “ALEXA.”

I chatted with the Support Team earlier this week.  We went through many troubleshooting steps, but they claim it must be an Amazon issue.  Amazon said the issue is Sonos-related.

 

To use the voice recognition feature, select (Settings) > [System] > [Voice Operation Settings], and then select the checkbox for playstation

Reply