Unable to set Sonos Era 100 as Alexa-enabled device in room/group using Alexa app

  • 28 March 2023
  • 83 replies
  • 4859 views


Show first post

83 replies

Facing the same issue with ERA 300. It’s be great if Sonos can acknowledge and provide a tentative fixing date.

Userlevel 1
Badge +2

Same problem here with an Era 100. 

Same issue as everyone else with my two new Era 100. Does not show up as Alexa enabled devices. Disappointing to say the least as they are sold as “Alexa devices”…

Userlevel 5
Badge +5

Same thing here. I’m in the beta programme and got the tech support people there to look into it - result “it’s an Alexa issue”.

I bought 11 Era100s to replace my 11 Ones. Set them all up today and then discovered this issue. Will be returning all 11. Sonos can shrug and say “it’s an Alexa issue” all day long, but Sonos is one who’s losing money from it, not Amazon. I wonder how much money they lose on returned merchandise. 

Had a chat with Sonos week before last where they admitted it is a Sonos software issue and it is on their side to fix. They said they are aware of the problem but could not give a resolution date…

Same. Awaiting fix for this Sonos please. 

Userlevel 7
Badge +18

Hi Everyone

If you are still experiencing this issue (which we believed had stopped happening outside of Germany) please submit a support diagnostic and post the given number along with a screenshot of the Alexa app showing a lack of Era units under “Alexa-enabled Devices”, as above. Thank you.

569097849

 

Userlevel 5
Badge +5

Hi Everyone

If you are still experiencing this issue (which we believed had stopped happening outside of Germany) please submit a support diagnostic and post the given number along with a screenshot of the Alexa app showing a lack of Era units under “Alexa-enabled Devices”, as above. Thank you.

Thanks Corry, my diagnostic number is 751178187.

I’m not able to get a screenshot, you’ll just have to take my word for it. My Era100s and my Sonos Five are not in the Alexa-supported list. The Sonos Five is expected; it doesn’t have a microphone. 

Pretty frustrating to hear that Sonos thought this was resolved despite all the evidence to the contrary (so many people reporting it and not even one single person posting that it works for them). 

I also can’t view my era 100 under the list of Alexa devices. My support diagnostic is 1427058777 and my screenshot:

 

Userlevel 7
Badge +18

Thanks @andyLux, @Kirk33 & @Justkaykay - I’ve passed those along.

Badge

Same issue in the US - 4648835. Both ERA 300 are still not showing in Alexa-enabled Devices section.

Hi Everyone

If you are still experiencing this issue (which we believed had stopped happening outside of Germany) please submit a support diagnostic and post the given number along with a screenshot of the Alexa app showing a lack of Era units under “Alexa-enabled Devices”, as above. Thank you.

Hi Corry, 

I have the same issue. My Era 100 (Cocina Sonos) and Era300 (Sala) still not showing as alexa enabled devices. Diagnostic number: 858997908

 

Userlevel 7
Badge +18

Thanks, @CesarDzMs!

Experiencing the same issue

619612689

Userlevel 7
Badge +18

A big Thank You to all who submitted diagnostics!

We have enough to work with now.

Userlevel 5
Badge +5

A big Thank You to all who submitted diagnostics!

We have enough to work with now.

Corry, can you confirm if the developers are actively working on this? And can you please give us a progress update?

Or you just don’t want any more reports cause it’s getting embarrassing now?

Userlevel 7
Badge +18

Hi @Kirk33 

The Alexa code is not ours to alter so we cannot work on it, but we are working together with Amazon regarding the issue. We cannot give you a progress update.

 

Diagnostic number: 1725967583

 

Userlevel 2
Badge

My diagnostic number: 1515374376

My Era100 is positioned in my kitchen, trying to add to it to a group called ‘downstairs’, the device itself is called ‘Kitchen’.

You can see my 2 ‘Sonos Ones’ do appear, but they are in there own groups in different bedrooms.

 

1814430503
 


Hope this gets fixed soon. I switched to Alexa because the Era doesn’t support Google Assistant. Disappointing to find that the integration doesn’t actually work right.

Badge

Same problem for me with an Era 300, from Spain.

737207275
 

 

294222562

 

Only my Roam and Beam appear as an Alexa enabled device. The Era 100 “Bedroom” does not.
 

 

Sonos needs to fix this. Obviously it works with roam and move. Even if it’s an “Amazon issue” other speakers from the same company work fine - so does Bose FYI. 

This is super frustrating. I bought a pair of Era 300 units to replace a pair of Play:3 units because they had Alexa support integrated. But without being able to associate the Alexa device with a room it’s kinda useless. I wasted a bunch of time troubleshooting this. I live in California, USA. Diagnostic id is 397887563. Here are some screenshots showing that Main Bedroom Sonos is an Alexa device but can’t be associated with a room.

 

Reply