Question

Timers intermittently fail. Everything else is fine. Why?

  • 21 January 2020
  • 3 replies
  • 53 views

Userlevel 4

For the last six months we’ve had a weird, intermittent issue with Alexa and timers on a Sonos One and a Beam. We get two problems, intermittently (for about 50% of all timers):

  • In response to “Alexa, start a N minute timer”, unit fails to respond, but starts the timer anyway; or
  • Unit responds affirmatively, but upon subsequent inquiry says “No timer is set” and/or it fails to go off.

They otherwise work perfectly in all respects; all kinds of playback, whether internet streams or local music library, and for all other voice commands & skills. In addition, the same timer commands do work consistently on a “real” Amazon Echo & Echo Dot on the same network.

Fixes attempted:

  • Factory reset, including deconfiguring, removing unit from both Amazon & Sonos accounts and re-adding after reset
  • Connecting via alternate networks (including all of: Wifi, Sonosnet, and fixed-wire network). Even tried a different ISP, temporarily.

Circumstances:

  • Alexa on Sonos devices otherwise works flawlessly for a variety of commands and skills
  • Amazon Echo devices on same network DO work correctly for all timers
  • Other voice assistants work correctly (Siri etc)
  • Wake word is active on intended device, going by visual indicator and music ducking
  • Devices in situ for >18 months but only misbehaving for ~ 6 months (no infrastructure changes were made around then)
  • Date & time set correctly
  • No particular time-of-day affected, although it does seem to be episodic (my wife would say, “is it working at the moment?”)
  • Local network is stable (routinely tests up to 1G wire rate, no packet loss, no STP topology changes)
  • Network located in Melbourne, Australia and routed through a UBNT EdgeRouter on a stable 250mbit/sec fibre link, static IPv4 address with correct reverse lookup, and a provider assigned /56.

We have a bunch of other Sonos devices (a couple of Play:1s, a Playbar, several Connects) on the same network. They’re mostly fixed-wire with wifi disabled. The absence of topology changes, or of any other symptoms, suggests this is (probably) not a Sonos mesh networking issue.

I contacted Amazon support and they said “you’ve already tried everything we would suggest, we’re out of options”. Thanks, Jeff.

It’s totally weird. Why just timers, and why just with Alexa on Sonos?

Any suggestions/thoughts welcome.

 


3 replies

Userlevel 1
Badge +4

@inopinatus 

 

Thanks for reaching out to the community.

 

I would like for you to send us a diagnostic and reply back with the number. I want to see if any issues shows up in the report.

I have the same problem - and looks like a lot of others do too:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-timers-not-working-unreliable-6829421

Userlevel 2
Badge +6

Hi folks,

Couple of suggestions, which may be useful. First, make sure that your Sonos System is currently up to date.

If that’s not the issue, try unplugging the power from your Sonos speakers and plug it back. Wait for few minutes for your Sonos products to come back online.

Lastly, check and make sure your time zone is set under Date & Time within the Sonos app. If that doesn't work, I'd recommend that you submit a system diagnostic within 10 minutes of trying to set an alarm, and post the number here.. 

Reply