"There was a problem adding Alexa"


Hello,

I've just purchased a Beam and Sonos One and went through the installation process.

I'm having a lot of trouble activating Voice Services on both of them, as I keep getting the "There was a problem adding Alexa" error message after it logs in to my Amazon account.

Both speakers appear in my Amazon account under "Devices" and also in the Amazon Alexa app (I can play music through them using voice via the Alexa application), however I can not control them via the microphones on the speakers.

Really eager to get to this fixed as I'm loving them otherwise.

Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

53 replies

Same here. I am now able to connect my Beam to Alexa. 🙂
Same issue experienced today in Sydney after setting up a new router with 2 separate devices. Tried to change the region country settings without success.

1 - Deregistered current devices on PC or tablet. Then refresh browser
2 - Close SONOS and Alexa Apps completely on smart device
3 - Disabled Alexa skill then activate again
4 - Add through SONOS app. 1st device allowed sign in straight away. 2nd device went through one ‘try again’ screen and was then successful.

Worked for me
Userlevel 2
Badge +1
Sadly I’m unable to get Alexa on a brand new Sonos one in Australia. I can’t add the skill through the iOS Alexa app, I can’t get signed in via the Sonos app, and I can’t see how others here changed their Amazon region to another country? That needs a valid address in that country. How’d you guys change your region?

latest app, latest version of iOS, the speaker is updated, but can’t get past the ‘problem’ screens.

please help - brand new smart speaker and it’s impossible to get Alexa installed or conducted. I’ve been at this for hours, read pages of forum posts.