Answered

Stops after one song

  • 5 October 2017
  • 41 replies
  • 4797 views

Updated my Play 5 and link to Alexa dot but will only play one song, even after forgetting all devices, still only one song?
icon

Best answer by Keith N 17 October 2017, 00:12

Olstar & mw2252:

Thanks for reaching out to us about this. We are currently gathering more information on this issue to get to a resolution as soon as possible. Does this happen on any other music service? Pandora, for example. Have you also tried disabling the skill then re-enabling the skill in the Alexa app?
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Userlevel 7
Badge +19
Hello there, Olstar:

Happy to help in any way I can. Mind starting us off with a diagnostic report of your Sonos system? This will help to give us some insight to what exactly is going on. Be sure to reply with the confirmation number it gives at the end. Much appreciated.
Userlevel 2
Badge +1
I'm having the same problem. When asking for an artist, Alexa states that she'll shuffle a list; this comes from Prime Music. However after 1 song the music stops and no queue appears to be in place according to the Sonos app.
I'm having the same problem. When asking for an artist, Alexa states that she'll shuffle a list; this comes from Prime Music. However after 1 song the music stops and no queue appears to be in place according to the Sonos app.

I would follow the Sonos reps advice and submit a diagnostic. Reply with the reference numbere here or you can post your issues and the reference number to the beta feedback page here:

https://sonos.custhelp.com/app/beta
Thanks sent diagnostics confirmation number is 7923694
Hello there, Olstar:

Happy to help in any way I can. Mind starting us off with a diagnostic report of your Sonos system? This will help to give us some insight to what exactly is going on. Be sure to reply with the confirmation number it gives at the end. Much appreciated.

Thanks sent diagnostics confirmation number is 7923694
Hi . Having same issue. Only plays one song and has trouble stopping playback. I have a hard wired internet connection into a play one. Some comments suggest this may be an issue? Diagnostics submitted 7957919. Thanks
honestly, after all the waiting, the "first quarter of 2017" release of this integration is completely underwhelming.
I anticipated Spotify would be part of it, but not yet... keep waiting... soon...
I suppose I will wait for the release to come out of beta and then move on if it isn't a whole lot better. if it remains as glitchy as it is today, I'm out.
honestly, after all the waiting, the "first quarter of 2017" release of this integration is completely underwhelming.
I anticipated Spotify would be part of it, but not yet... keep waiting... soon...
I suppose I will wait for the release to come out of beta and then move on if it isn't a whole lot better. if it remains as glitchy as it is today, I'm out.


The "first quarter of 2017" nonsense is a myth, a misinterpretation by the press. The actual press release (see link), and every official statement by Sonos after, stated "with general availability in 2017".

http://press-us.sonos.com/134980-sonos-with-partners-and-industry-leaders-ushers-in-new-era-of-connected-home-listening

Also, Sonos was dependent on Amazon releasing their API for 3rd party speakers, which was not officially released until late last month. Without this API, there was nothing Sonos could do. This was a joint effort, with at least half the work being on Amazon's timeline.
Userlevel 7
Badge +19
Olstar & mw2252:

Thanks for reaching out to us about this. We are currently gathering more information on this issue to get to a resolution as soon as possible. Does this happen on any other music service? Pandora, for example. Have you also tried disabling the skill then re-enabling the skill in the Alexa app?
This is the same basic issue I'm seeing as well. You can add devices and it works for one song. It will then never play a song again in that zone or any other zone.
stevenic,

Perhaps you would be so kind as to submit a system diagnostic, and post the number here, for the folks at Sonos to look at?
stevenic,

Perhaps you would be so kind as to submit a system diagnostic, and post the number here, for the folks at Sonos to look at?


My diagnostics number is: 7967100

And yes... I've tried disabling and re-enabling the skill. Same issue.
Yea, better to let Sonos look at the diagnostic. You've done all the things I'd have recommended already.

I suspect it gets more complex from here, since the diagnostic only has data from Sonos' side of the issue, so if the problem is somewhere in the Alexa universe, they wouldn't be able to see it in the Sonos logs. They'd only see what Alexa sent to Sonos as a command to actuate on.

Good luck!
My issue is a bit more involved. It just started working somewhat reliably in one zone but still doesn't work at all in any of my other 4 zones. It's totally crazy.
Well, we'll find out when Sonos responds to the diagnostic!
Userlevel 7
Badge +19
stevenic: Thanks for the diagnostic. As you may have seen in the thread we are currently gathering information on this problem. It seems that report was incomplete or corrupt. Would you mind submitting another? Also, does this happen on Amazon Music, Pandora or both? Since re-enabling the skill, have you re-discovered your devices?
Hi. Yes I have disabled and re enabled the app. And I have turned it all on and off. The issue is with amazon music . Im not sure what pandora is? Tune in plays continuously but again will not stop on command through alexa.
Userlevel 7
Badge +19
Hi. Yes I have disabled and re enabled the app. And I have turned it all on and off. The issue is with amazon music . Im not sure what pandora is? Tune in plays continuously but again will not stop on command through alexa.
We want to verify that we are disabling and enabling the Sonos skill in the Alexa app and not simply closing the app and re-opening it. Since re-enabling the skill, have you rediscovered your devices? At times after re-enabling the skill, the speakers will need to be re-discovered in the Alexa app in order to be found.

Since you have disabled and re-enabled the skill, please replicate the problem and send us another diagnostic to take a look at the errors coming up. We need to see if the errors given internally are the same. Much appreciated.
7972271 here are the new diagnostics . I understand disabling vs closing the app. I have disabled it again and can confirm the glitches are still present. Alexa will play music on a speaker but wont stop the playback as she thinks it is a camera device on that command and will only play one song and therefore will not skip to the next track either. Thanks
Userlevel 7
Badge +19
Thanks for the diagnostic and your patience with this, mw2252. At this point, we want to gather more information to get this escalated up to our senior technicians. I'll send you a PM in a moment with some of the details we will need to build the ticket.
I'm having similar issues. Sonos stops playing from Amazon Music after 1 or 2 songs. It seems it doesn't matter whether I start playing via Alexa (Echo Dot) or via the Sonos App for iPhone. I initiated Amazon Music via Alexa, but when the music stops after one or two songs, I went to the Sonos App and pushed next, and then Sonos played another 1 or 2 songs before stopping. As someone else noted somewhere, In the Alexa Web app it seems that the music continues to play, and if I push next music comes out of the chosen Sonos loudspeaker.

Diagnostic no.: 7988323

Looking forward to a solution.
Userlevel 7
Badge +19
Hello there, jakobjul: Thanks for the diagnostic report and for reaching out to the Community. Have you tried disabling and re-enabling the Sonos skill in the Alexa app? We have had many customers report that this should get things back working as intended. Let me know if you find this helpful.
Hi Keith,
I followed the steps you proposed to others, meaning disabling, enabling and re-discover. Alexa runs in German and Sonos in English.
Userlevel 7
Badge +19
Thanks, jakobjul. I noticed you have a couple other music services. Does this only happen with Amazon Music or do you experience this on Apple Music or Deezer? We may need to start collecting screenshots of the complete Groups and Devices list in the Alexa app to get to our Senior Technicians. If so, would you mind sending me a PM and I'll go over what exactly we need?
Userlevel 3
Badge +1
HAD, the same problem.

Was on the phone with Tech yesterday for about a half hour. Here’s how we fixed it:

1. Open your Alexa app
2. Go to Skills, Open the Sonos skill and disable it.
3. Once Skill is disabled, re-enable it and follow the steps to hook up to your Sonos account.

Should start working again as designed.