Spotify doesn't work on Era 100 or One


I recently bought the Era 100. It all works fine except for being able to play music on voice command.

Alexa responds to other voice commands like alarms, the weather, accessing radio stations via Tune In etc. But when I say "Alexa, play [so and so] on Spotify" Alexa responds by saying "Here is [so and so] on Spotify". But nothing after that happens.

I also own a Sonos One and it worked fine. But ever since I bought the Era 100 (I had to update the Sonos app to setup) now the Sonos One doesn't work for music requests either.

I've disabled the skill in the Alexa app and reinstalled, reinstalled sonos app, added alexa voice service but nothing helps. 

Any help would be appreciated. 


Best answer by ollycaz 9 May 2023, 13:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +18

Hi @ollycaz 

Welcome to the Sonos Community!

It sounds like the account security tokens that are exchanged between the services has been corrupted.

Please try these steps:

  • Disable the Sonos skill in the Alexa app: Alexa app » More » Skills & Games » Search Alexa Skills and type Sonos » Sonos » Disable Skill.
  • In the Sonos app, go to Settings » Services & Voice » Amazon Alexa » go through each room with Alexa installed in turn and Remove Alexa » Confirm.
  • Once all copies of Alexa have been removed from Sonos rooms, go back to the Alexa app
  • Alexa app » More » Settings » Device Settings » tap each Sonos-related entry here and tap Registered To (Deregister).
  • Once all Sonos-related entries have been deregistered from the Alexa app, return to the Sonos app.
  • Sonos app » Settings » Services & Voice » Add a Voice Assistant » Amazon Alexa and follow the on-screen prompts. Our Set up Amazon Alexa with a voice-enabled Sonos speaker help page has full instructions.

I hope this helps.

Thanks @Corry P

I followed your steps but still no luck. Its strange that other Alexa commands work fine and when i try to play music by saying 'Alexa, play [Xx] on Spotify' it responds as though it's working ('Here is [xx] on spotify') for example, but nothing ends up playing in reality.


I can connect my Spotify app on my phone to the Era 100 and start playing music, and weirdly, once it's playing I can say 'Alexa, next song' and it plays the next song on my playlist just fine.



Userlevel 7
Badge +18

Hi @ollycaz 

Transport controls (Play, Pause, Next, etc) work a little differently than a request for specific music, and should work regardless of the source - even if Alexa doesn’t support the music service in use - so that makes sense.

As to getting Alexa to play Spotify tracks on your Sonos device again, I can now only recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports. Be sure to mention the steps you have tried already, though they may take you through them once more just to be sure.

I hope this helps.

For the record and for anyone this may help in the future. 

I solved the problem. The problem was with Spotify. I logged out of Spotify, uninstalled Spotify, reinstalled it and upon reinstallation there appeared to be some updates, it automatically asked me to connect with Alexa. Then all Alexa voice commands worked fine!

Userlevel 7
Badge +18

Hi @ollycaz 

Fantastic! Thanks for updating the thread with your fix!

Hello Corry, thank you for your advice. I was close to get crazy with install and uninstall Spotify/Sonos/Alexa…. But it works fine now.

Thank you for your support