Sonos speakers won't play via Alexa group (voice command)

  • 6 November 2021
  • 2 replies
  • 39 views

I've owned two Sonos ones for 3 years now and I can not get the two to play music via alexa. It simply doesn't work. Countless attempts, no real answer from Sonos on it. I've grouped them together as a group in alexa app (the preferred speaker option for both speakers isn't there anymore, can only select one of the speakers or built in speaker) and it still won't work.

It's like it's not compatible despite saying it is. I love the Sonos products for their audio quality but voice integration is very poor and poorly advertised as alexa compatible. I know you can't link alexa products with Sonos in a group but can't understand why the Sonos groups won't work. If anymore has ever got this working I would love to know how, as it just seems like I'm banging my head against a wall.

 

Thanks


2 replies

You should be seeing something like the attached image for your Alexa ‘enabled’ groups…

Have you tried removing/reinstalling the Sonos ‘Skill’ in the Amazon Alexa App?

Just to add, the Alexa groups are working fine for me - perhaps ensure your groups are not duplicated, or the devices haven’t been split into other groups.

Also, if you goto the 3rd speaker section within a group and select ‘Change’ then on the next displayed form, scroll to the foot of the page (past your list of devices), where you should see a new feature to change the ‘group playback options’ - perhaps check those options are set to what you are looking for.. I usually opt to set my own groups to ‘Always’ (albeit I do have some group exceptions).

Reply