Answered

Sonos One won't group with other Sonos speakers

  • 1 October 2021
  • 4 replies
  • 43 views

I'm trying (and failing) to get my Alexa-enabled Sonos One to play music through my other Sonos speakers (six in all). I've set up a group on the Alexa app (whole house), added devices (all Sonos speakers), added my Alexa device (Sonos One), selected “always” so I don't have to specify each room … and when I ask Alexa to play music it only plays on my Sonos One, the rest of the speakers are silent.

I've seen lots of references to setting a preferred speaker but can only find this option on the Sonos One settings and my choices are either “built-in speaker" or, under wifi speakers, my Sonos speaker in the Living Room. The option “Let Alexa choose: Alexa will select speakers in the Whole house ...” is greyed out. Clicking on “Learn more" tells me to go to Devices, select the group I want to change, go to the Preferred Speaker section - and that's where I get stuck, I can't find the Preferred Speaker section.

Can anyone help, please. I've been messing about with this for the best part of a day and am getting nowhere.

Many thanks

icon

Best answer by ratty 1 October 2021, 20:23

View original

4 replies

Why not simply group the speakers with the One, using the Sonos controller app? 

I was trying to find a way round using the Sonos app as it seems to drain the battery on my tablet.

On some devices the Sonos app might not sleep in the background. Force-quit it and it’s gone. 

By the way, to be clear, a grouping operation is persistent. The controller sends commands. They get executed. The controller doesn’t need to be running thereafter at all. 

Tks, Ratty, that's useful info.

Reply