Question

Sonos One problems

  • 23 October 2017
  • 66 replies
  • 8401 views

Userlevel 5
Badge +11
  • Chromatic Producer I
  • 342 replies
My Sonos One arrived this morning, I've unplugged my Echo and setup the One in it's place ready for use. I've upgraded to 8.1

Problems....

- You cannot change the wake word from Alexa.

- Music does not play. I say "Alexa, Play some UB40", Alexa confirms and says it is playing but no sound comes out.

- Other non Sonos skills don't work e.g. Hue. If I say "Alexa, turn on the Hall lights", Alexa says that the hall is not responding. This works fine from the Echo when plugged back in.

- The white light on the unit does not turn off when you disable it in the settings

- With the Echo plugged back in I say, "Play UB40 in the Kitchen" I either get "Shuffling songs by UB40 in the kitchen, something went wrong" or "Cannot find songs by 'UB40 in the kitchen' " :)

Anyone else have issues like this?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

66 replies

Userlevel 2
Badge
I also unplugged my Echo and replaced with the Sonos One - I'm UK based. After using the Alexa App to configure UK localisation settings, all seems to work okay. I use the 'Alexa' as my wake-up word, so can't comment on that. I can get Sones One Alexa to control Sonos music in other rooms and to turn lights on/off etc. There appears to be a longer delay than the previous Echo to respond, and I can't change Alexa's voice from North American to British though.
Userlevel 2
Badge
Since this, I have discovered that if you change the Wake-up Word on the Alexa App from Alexa (US) to Alexa(UK) - it changes to a UK accented Alexa voice.
Userlevel 5
Badge +11
I've got Hue working, I removed Alexa from the unit via the Sonos app and then added Voice services back.

Still no music though, I say "Alexa, play radio", shes says it's playing but nothing happens

I have the British voice, try setting the timezone in Alexa app > Settings > Sonos One, it defaults to US
Userlevel 2
Badge
I disabled the white light in settings and it worked fine on my Sonos One.
Userlevel 5
Badge +11
I disabled the white light in settings and it worked fine on my Sonos One.

I still have a light under the mic that is always on. The option in the setting does work and turns off the light in the centre. Is the light under the mic always on for you?

Other problems found..

- if music is playing I say "Alexa, next track", she says it can only be done when music is playing

- "Alexa, stop" does not work when music is playing

I think I have a dodgy unit 🙂
Userlevel 2
Badge
I presume the one under the mic is to show that it's in Alexa listening mode. I guess if you were too disable Voice Services it might turn off ?
Userlevel 5
Badge +11
All the reviews suggested a circle of lights when Alexa is listening, mine just makes the centre light glow.
Userlevel 2
Badge
Mine does the same
Also in U.K. and normally use “Echo” wake word so annoying that I can’t change the One to do the same!
Main white light can be turned off but the Alexa mic light still on - will have to see if a problem as this One is intended for bedside use.
Userlevel 2
Badge
@JohnWD - MIne's bedside too. If you find a simple way of disabling the mic light (without disabling Alexa), please let me know.
@JohnWD - MIne's bedside too. If you find a simple way of disabling the mic light (without disabling Alexa), please let me know.

There is no way of disabling the microphone LED short of opening the case and desoldering the connection. Sonos has hardwired the LED to the microphone operation in order to ease the worries of those prone to believe the device will be used to invade one's privacy.
Userlevel 5
Badge +11
Also in U.K. and normally use “Echo” wake word so annoying that I can’t change the One to do the same!


It is annoying, I can't use Alexa as it's too similar to someone's name in the house.
Userlevel 7
Badge +26
@JohnWD - MIne's bedside too. If you find a simple way of disabling the mic light (without disabling Alexa), please let me know.

There is no way of disabling the microphone LED short of opening the case and desoldering the connection. Sonos has hardwired the LED to the microphone operation in order to ease the worries of those prone to believe the device will be used to invade one's privacy.


Confirming that this is correct. It's a security feature and there is no way to work around it, by design.

For bedside use, if the light is bothering you, the only option is to cover it with something. Or, press the microphone symbol on the player to turn off the microphone and therefore the LED. Though, this will, of course, turn off voice on the unit temporarily.

Also in U.K. and normally use “Echo” wake word so annoying that I can’t change the One to do the same!


It is annoying, I can't use Alexa as it's too similar to someone's name in the house.


Currently, the Sonos One will only respond to Alexa. We're constantly working on new things with the Sonos One, so if at some point in the future we get some extra wake words added, we'll make sure to let everyone know.

As to the playback trouble dave77 is talking about, I'd suggest disabling the Alexa skill for Sonos, restart your Sonos devices, then re-enable it and see how it goes. If you keep having trouble, the team would love to work with you, so I'd advice that you give us a call on our support line.
Currently, the Sonos One will only respond to Alexa. We're constantly working on new things with the Sonos One, so if at some point in the future we get some extra wake words added, we'll make sure to let everyone know.
+1 for this, I received it today and using Alexa only is proving tricky.
Userlevel 5
Badge +11


Currently, the Sonos One will only respond to Alexa. We're constantly working on new things with the Sonos One, so if at some point in the future we get some extra wake words added, we'll make sure to let everyone know.

As to the playback trouble dave77 is talking about, I'd suggest disabling the Alexa skill for Sonos, restart your Sonos devices, then re-enable it and see how it goes. If you keep having trouble, the team would love to work with you, so I'd advice that you give us a call on our support line.


Thanks, but if Alexa is the only wake word then it's no good for me
Since installing the One (UK) today my other vanilla Echo devices seem to be occasionally speaking with a US Alexa voice. This is in response to an erroneous perception of the wake word with a command request I haven’t been able to work out. The One and all other devices are set to U.K. English. Anyone else experienced this?
Same exact issue with asking Alexa to play music
ME: "Alexa play Dave Matthews Band" >> Alexa:"Shuffling songs by Dave Matthews Band" >> Crickets "..."
Userlevel 1
Also disappointed that you can't use Echo as a wake word. This is what I'm use to and use for my dots in the other rooms so hopefully this changes soon.
Same here .. Starting some skills just results in silence. Spotify is not supported. This isn't how I imagined it 😕
Love the concept, but if the wake word can't be changed, this is of no use to me, and I will have to send it back.
alexa just saying on the new paly 1 "soory having trouble right now please try again later"
Userlevel 7
Badge +26
You can change the accent of Alexa, in the Alexa app for your Sonos One. Make sure that you have the region set correctly and the language set to UK. That should do the trick from what I've seen here from others on the community.

Also, if anyone's having trouble playing music on a Sonos One with Alexa, there are some things to check. First off, make sure you have the Sonos Skill enabled in the Alexa app. If it already is, it's good to disable it and then enable it again.

After that, say "Alexa, discover devices." And try it again.

Please note, Spotify isn't available to start playback on Alexa for Sonos just yet. We're working on it, but for now you'll have to use another service on Sonos using Alexa. Or, you can use Spotify but start it from the Spotify app or the Sonos app. Alexa can adjust volume and change tracks from any source.
My sonos one only respond to Alexa when you’re about 1-2 feet away. Any further and there’s no response. When music is playing, no response at all.

Sometimes, when I raise my voice to get a response, the sonos one does nothing, but other echo devices in other room respond!

Worst sonos product I have owned. Looking to get a refund.
Badge
Yes , I agree with the general sentiment, very disappointing product.... not as feature rich as an Echo. The killer for me is that spotify doesnt work at all, and any request for music get routed to amazon music....am I the only one that thinks that is a bit too much of a coincidence.