Question

Sonos One plays wrong song

  • 23 May 2020
  • 8 replies
  • 166 views

  • Contributor I
  • 1 reply

In the last two weeks or so, my Sonos One does this thing where I’ll ask it via Alexa to play a song and it will play whichever song I was listening to prior.

 

For example, if I listened to “Halo” by Beyoncé five minutes ago and then I say “Alexa, play ‘Perfect’ by Ed Sheeran,” it will start playing “Halo.” Per another person’s question I saw on here, I’ve disabled Alexa in my Sonos app, deregistered my Sonos in my Alexa app, signed out of all Amazon apps on my phone, and then reenabled Alexa voice services on my Sonos, reregistered my Sonos in my Alexa app, etc. and it’s still acting up. Any tips?


8 replies

Which music service are you using?

Amazon Music

I have this problem, too.

Setup 1: Amazon Echo with preferred speaker associated to a group of seven Play:1 speakers located downstairs.

Setup 2: Amazon Show with preferred speaker associated to a single Play: 1 speaker upstairs.

In either setup, I ask the Amazon device to play a song and let it complete.  When I ask the Amazon device to play another song, it begins playing the PREVIOUS song.  Sometimes, it plays the previous song for 1-2 seconds then stops and goes silent.  Other times, it plays the previous song 1-2 seconds then stops and plays the second song as requested.

Google Play/Assistant doesn’t have this problem when linked to Sonos.

 

If I manually select “End Session” from the queue in the Sonos App, the unwanted behavior goes away and Amazon/Sonos will play the requested song without trying to play the previous song.  

Userlevel 1

Yep same here.  
 

Asking for song plays the previous song.  Been doing this for the last few weeks, was hoping that it would fix itself, but it hasn’t.  This behaviour is when using Amazon music, via voice (in my case Alexa) to my play:Amps.

 

Very annoying.  Anyone have a fix?

Andrew S

Userlevel 1

Anyone ?

Badge

Exactly the same issue here - and also started in the last few weeks.  I have 4 Sonos One’s about the house now, some Gen1, some Gen2 and one SL.  It doesn’t always happen but never happened until recently, having had the setup for a few years now.  I’ve also (this week) had an issue where I ask Alexa to play something, she introduces the song “Playing xxx on Amazon Music”, then “Here’s xxx” (ie two intros) - and then says “I’m not sure what went wrong” and plays nothing.  Not sure if it’s related, but I think Alexa has gone a bit mad?

Userlevel 4
Badge +5

Same issue here on a One. It only happens randomly though. Usually the next day it starts to play the song from the evening...

Hey guys,

I’m sorry for the late response. I would like to ask each of you to send us a diagnostic and reply back with the confirmation number.

Reply