Sonos One doesn't work with Hue?

  • 23 October 2017
  • 35 replies
  • 16660 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

35 replies

I had this same issue and just corrected it by removing the light bulb that was giving me issues on my Sonos One from the Hue app and re-adding it
As I put a decent amount of time and nerves into fixing this issue I want to let you how it worked out for me in the end.

Problem was: Alexa App/Sonos One couldn't dicover my Hue Bridge V2 (which I actually only bought because I thought the V1 one was the problem in the first place).

Strange was: Bridge and bulbs worked fine with the Hue App on iOS as well as with Siri/Homekit.

After trying out every suggestion I found on the internet, updating every imaginable piece of firmware (router, bulbs, you name it ...), messing around with port forwarding and deleting/delinking/reinstalling/reconnecting almost every app and skill involved I almost gave up.

Although the bridge was working fine with the Hue App and also showed up as connected in my account on the Hue website I somehow decided to delete it. After reconnecting the bridge with my account there is way more Information about my bridge available on the website AND it was discovered by the Alexa App in an instant!

Glad if this helps anyone else.
Wow. Months later and I am having the same problem with my v1. I can't tell from here if I am supposed to be able to use this or if I need to buy a new Hue hub. It's too bad Sonos doesn't seem to monitor/help people on here. Not impressed with the level of support being provided for these products.
Userlevel 7
Badge +22
Hue lights work fine on my Sonos One. You probably need to look at how Alexa and Hue are communicating (search internet for Hue and Alexa issues) to solve problem. It shouldn't be an issue with Sonos - it should be an Alexa issue and your setup. V1 bridge or V2 bridge doesn't matter. As you can see from the 1st reply above - that person to found it to be an Alexa/Hue not setup properly. Remove Sonos from the equation and focus on the Alexa app and Hue.
For the amount of money I've spent on Sonos products, I shouldn't have to spend hours trying to fix things. I've followed the directions and they haven't worked. Getting technical support is proving to be a nightmare.
Userlevel 7
Badge +22
It has nothing to do with Sonos that is your first problem. It is an alexa and hue issue.

If your frustrated call Sonos support as they will still help you.
Badge
I can confirm that Sonos One works with Philips Hue v2 without existence of an Echo Dot in the mix. Had to add the Hue skill in Alexa app to connect Alexa to the Hue. Haven't had any problems for over a few weeks now. Just have to state the obvious here, make sure the mic is on for the Sonos One:8
It's not V2 I am having the problem with. It's V1. I've ordered a new square hub, as there are other reasons to upgrade
Hi, I'd been having the same issue. Realised I hadn't confirmed my email for my Philips account. Ended up re-adding my bridge.
Try this:
Go to philips website https://www.philips.co.uk/c-m-li/hue
Make sure you have an account setup and that you've confirmed the email address.
As I had an old bridge, I deactivated it and then added my new bridge. Maybe do this anyway, even if you don't have a new bridge.
Alexa then discovered my lights instantly.