Question

Sonos One Alexa is half baked - Smart Home doesn't work?

  • 23 October 2017
  • 36 replies
  • 3377 views

I didn't see this advertised anywhere but after setting up my Sonos One with Alexa it seems that any smart home devices do not work. All works perfectly with my echo dot but the Sonos Alexa is kind of a half baked approach.

Is that just me? Sonos admins please let me know if I'm doing something wrong.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Userlevel 7
Badge +21
The Sonos:1 shouldn't have any effect on any existing smart devices.

And if you want a serious response you're going to have to make a bit more effort in describing your concerns more thoroughly rather than just saying "half-baked"
ok Stu - I have the new Sonos One with Alexa. I've followed all the set up process.
In the Alexa App it shows my device as "offline" which is probably why I cannot control smart devices using Alexa.
I'm not sure what to do to get it to show up as Online (my echo dots are online).

Any ideas?
Userlevel 7
Badge +26
Hi JDW712, have you tried rebooting that Sonos One by unplugging the power for a few seconds? Also, try discovering devices on it. If that doesn't do the trick, can you submit a diagnostic from your Sonos system and reply back with your confirmation number?
No joy - have submitted Diagnostic. Conf number 7993600. I've tried everything, even setting up as an entirely new system. It still shows as "offline" in the Alexa App and hence unable to use
Userlevel 7
Badge +26
Thanks, taking a look now. When you try to discover devices, does it show up briefly or is it always offline?
Always offline unfortunately. FYI I’m travelling today so may not see response for a day or two. Much appreciate your help
Userlevel 7
Badge +26
Ok, in that case, when you get back, I'd suggest discovering again and see if that does the trick. Tell Alexa to discover devices.

If that fails, can you send a new diagnostic?

I'd suggest at that point to give us a call on our support line.
Thank you. I will do so!
Not sure if this will help, but maybe remove the offline device from the Alexa app and then ‘discover’ your devices again. I had a similar situation and found the speaker had a different name to what I gave it.
I can "see" my new Sonos One in the Alexa app but cannot do much with it. I cannot change the wakey word etc. Sounds fantastic however! Just cannot yet replace a dot. I had the impression it would work simular to an Echo but have not figured it out yet in my first couple of hours of toying with it.
Userlevel 1
Badge +1
I would agree with the original post. Sonos One, cannot find Nest thermostats, iHome smart plugs, Arlo pro cameras, the list goes on. I have tried manual discovery, as well as verbal. Alexa states there are no smart devices available.
Userlevel 1
Badge
JDW712 Have you try removing your skill from from echo dot and add it again it worked for me I have no more issues controlling my light lock my front door open my garage door list goes on for me it worked since I did it


Michel
Badge
Same here, Hue doesent work, Harmony Hub doesent work.
Userlevel 2
Badge
My Lutron Caseta works perfectly with my echo dots and Sonos One. What you mat want to do is a factory reset, remove all from the Alexa app or Amazon login and start again.
Badge
Factory reset of what? I already disabled/enabled the harmony and hue skills. Removed and re-added the voice service. With my Echo and my Echo dot all works perect, not with the Sonos One. Also One doesent seems do recognize IFTTT triggers.
Userlevel 2
Badge
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED).
Userlevel 4
Badge +4
I also had the Sonos One showing as "offline" in the Alexa app. I fixed this by going into my Amazon account on my laptop and deleting the Sonos One from my Amazon devices. I then rebooted the speaker. Finally, I added it back into the Alexa app. Everything now works. Hope this helps.
Badge
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED). I tried that, but no success 😞 But thanks anyway!
Userlevel 7
Badge +20
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED). I tried that, but no success 😞 But thanks anyway!

If you are having problems please follow the steps I've listed in the Answer to this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
Badge
thanks i tried that, but no success, I strugle on the last step:

Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';


My Sonos One is shown as 'Off Line' 😞
Userlevel 7
Badge +20
Please select Alexa App>Settings>Devices>'Your Sonos One' you should see an option to turn 'On Line'.
Badge
unfortunately i don't see this option 😞
Userlevel 7
Badge +20
unfortunately i don't see this option :-(Can you confirm that you selected the device 'name' Amazon Alexa Enabled Play:1?
Badge
No the Device is names "Sacha''s Sonos One"
Userlevel 7
Badge +20
Within Alexa App>Settings>Devices there should two devices listed, one that matches the name within the Sonos app and another for the Alexa Component which if registered to you will be named Sacha's Amazon Alexa Enabled Play:1.