Answered

Sonos Beam self-mutes after playing Alexa music

  • 1 January 2021
  • 7 replies
  • 62 views

Whenever I ask my Sonos Beam to play music using, “Alexa, shuffle songs by the McGuire Sisters” and later stop the music with “Alexa, stop”, I’ve noticed that the Beam will be in Muted state and cannot be unmuted verbally. I must manually grab the remote for my connected Roku TV and raise the Volume from 0 to 40.

For example, say I’m watching YouTube on the full-HDMI connected Roku TV (TCL brand with CEC enabled), using my HP PC’s web browser. I hear audio fine at the expected Volume level (40). I then listen to a random song via Alexa – the Sonos/Roku volume remains 40 – then ask it to stop, as outlined above. Music ceases playing, as expected. Resuming the paused YouTube video, however, results in no sound! Volume level is now 0 (but never actively displayed on-screen as such).

Saying, “Alexa, volume 4”, or pressing the PC’s up-vol button on the keyboard (I realize that’s a separate volume setting, but I want to assure readers here that it’s at max. vol.), doesn’t help. ONLY THE ROKU REMOTE’S VOL UP button has the effect of raising the volume back from 0.

Weird, no?

icon

Best answer by LibraSun 14 January 2021, 15:36

SOLVED!

Turns out my suspicion that this is a TCL Roku TV issue and not the Sonos or Alexa itself was correct. I made three specific changes on the TV’s Settings:

  • TV Inputs > “Computer” (HDMI1) > HDMI Mode > from “Auto” to “2.0”
  • Audio > S/PDIF and ARC > from “Auto Detect” to “Auto-Passthrough”
  • Audio > TV Speakers > from “On” to “Off” (elective, likely not relevant)

Now, whenever I initiate music via Alexa, then stop it with “Stop”, and subsequently resume audio content on my HDMI-connected PC, the TV’s volume correctly resets itself from 0 to the previous level. The ramp-up takes approximately 3 seconds.

I’d like to leave this Topic active in case other users with similar setups encounter the “stuck ducking” problem. Thanks!

View original

7 replies

Userlevel 5
Badge +14

Hi @LibraSun,

Thanks for reaching out to the Sonos community and for letting us know about your concern. To help you check the volume issue with your Sonos Beam, would you mind replicating the issue and submitting a diagnostic report for us to check? Please don't forget to include the confirmation number in your response to look into your system and find out the cause. Please feel free to reach out if you have further questions or concerns, we’ll be glad to assist you. We'll wait for your reply.

Done. Just submitted case #515410768

Userlevel 5
Badge +14

​HI @LibraSun

Thanks for your response and for submitting the diagnostic. Based on the report, your Sonos Beam is not muted. However, a slow network connection was detected and there's interference in your wireless network that may be caused by wireless congestion or low wireless range; which may be causing the issue with your Beam.

To help you out with this, please follow the steps below and see if it works.

  1. Sequential reboot to refresh your network and all your Sonos devices connection.
    • Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
    • Once the router is back online, unplug all your Sonos devices from the power.
    • Please wait 15 seconds before you plug back them back in.
    • Force close the Sonos app from your iOS or Android device.
    • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
  2. Adjust TV audio format
    • Sonos home theater products are compatible with stereo / PCM, Dolby Digital 5.1 / AC3 auto formats. 
  3. Adjust the group audio delay
    • Settings > System > Tap your Sonos Beam > Group Audio Delay and then choose a delay option.
    • Observe your Sonos system performance.
  4. Relocate your Beam or move it closer to the router to determine if it is a wireless range issue.
  5. Hardwire one of your Sonos speakers to your router (not your modem).
    • Observe your Sonos system performance.

If you're still experiencing the issue, I recommend contacting our phone support with your full network setup including the make and model of each device, and for more in-depth troubleshooting steps.

Please let me know if you have any further questions or concerns, we'll be glad to assist you.

Thank you for those suggestions, and I promise to follow that list to the letter tomorrow. However, let me clarify one central point: The muting I spoke of is evidently being done TO THE TV itself (by the Sonos/Alexa), such that I must use the TV’s REMOTE to undo the muting.

I believe this is partly intentional behavior -- do they call it “ducking”? -- whereby the Sonos, in order to produce music, naturally wants to the TV to be silent whilst playing. However, some part of the process is neglecting to tell the TV, “We’re done playing music, please resume your previous volume level.”

It’s that which I consider unwanted behavior, and accordingly needs to be teased out.

Userlevel 5
Badge +14

Hi @LibraSun

Thanks for your response and for updating us. My apologies for the late response. In the report you submitted, there's no instance that the TV remote mute your Sonos Beam. This could be with the Alexa configuration. When was the last time it was working fine, any changes? Have you checked Alexa settings in the Alexa app to check why it's muting even the command is to stop the music? Sonos only responds to the command.

Let us know how you get on with the advice above. If you need help with any other information, please be sure to let us know.

I’ve gone as deep into analyzing this setup as possible on this end, and concluded that:

(a) Alexa (built into my Sonos Beam, so excuse any confusion as to “Who’s in charge?”) is telling my Roku TV to “Mute” itself whenever she begins playing music in response to my verbal command.

(b) For some reason, Alexa either fails to issue an “Unmute” or, more likely, the Roku TV is failing to execute that command correctly. I say “More likely” because I observe a number of other Roku TV owners complaining of this very issue, meaning their TV drops to 0 volume and can only be manually raised from volume 0 using the TV’s own remote.

[c] Accordingly, I was wrong to post this Topic here in the Sonos Community.

(d) I have no way to trace what’s being negotiated (via ARC on HDMI) between the Alexa-enabled Sonos and my TV.

[e] I strongly suspect that this can/will be remedied by a Roku TV firmware update.

(f) I did tweak one or two settings in the Alexa app, as well as the TV’s Settings page, to ensure things like “Compatible audio formats” and “Signal pass-through” were set optimally, but can attest to none of those changes curing the underlying problem.

 

Thanks for all the moral support!!

 

 - Libra

 

SOLVED!

Turns out my suspicion that this is a TCL Roku TV issue and not the Sonos or Alexa itself was correct. I made three specific changes on the TV’s Settings:

  • TV Inputs > “Computer” (HDMI1) > HDMI Mode > from “Auto” to “2.0”
  • Audio > S/PDIF and ARC > from “Auto Detect” to “Auto-Passthrough”
  • Audio > TV Speakers > from “On” to “Off” (elective, likely not relevant)

Now, whenever I initiate music via Alexa, then stop it with “Stop”, and subsequently resume audio content on my HDMI-connected PC, the TV’s volume correctly resets itself from 0 to the previous level. The ramp-up takes approximately 3 seconds.

I’d like to leave this Topic active in case other users with similar setups encounter the “stuck ducking” problem. Thanks!

Reply