Question

Sonos Beam & Alexa - Sorry I am having trouble understanding right now - please try a little later

  • 5 January 2019
  • 9 replies
  • 528 views

Hi I have a Sonos beam that has continual problems with Alexa integration. I have restarted the beam re-installed the Sonos and Alexa app disabled/re - enabled Sonos skills and it still does not work. Sometimes it has worked but then fails after a period of time. At the moment it just doesnt work - any ideas?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Hi Ken, thanks for your help. I just wanted to let you know that i found out what the problem was in the end. My wife had changed the password to our Amazon account and I needed to re-enter the password to get it working again. Thanks.Ah good news. Thanks for the reply and feedback. Glad to hear it’s all sorted.?
Hi Ken, thanks for your help. I just wanted to let you know that i found out what the problem was in the end. My wife had changed the password to our Amazon account and I needed to re-enter the password to get it working again. Thanks.
Just a single AP, in the same room as the TV/Sonos beam.Is that access point perhaps on a different channel to your main WiFi? See what happens if you put all on the same wifi channel.
Just a single AP, in the same room as the TV/Sonos beam.
Do you have nearby wifi access points or are you using mesh hubs perhaps ?
Thanks Ken I have a Sony TV connected to the Sonos beam. I tried disconnecting but it continues stating “Sorry I am .....”. Thanks for trying to help though.
DGarwood,

Do you have other HDMI-CEC controlled devices attached to your TV HDMI Ports and is it a Samsung TV? If the answer to either question is 'Yes', my guess would be that the Sonos device is losing connection periodically to the other CEC enabled devices.

Try disconnecting the other devices from your HDMI Ports, just as a test ... plug them back in one at a time to test each one over a period of time to find the culprit and then either turn off the CEC controls on that 'offending' device, or use a CEC-less adapter, or cable to stop it stealing the control away from your Beam.

Some TV's have an 'auto detect HDMI' setting too in some instances and it can/should be turned off, but even that may not stop some devices taking CEC control.
I can stream music and video and no red lights on my router. I think the internet is ok.
Is your internet access failing? Usually, that phrase is because Alexa can't reach the Amazon servers.