Question

Sonos beam: Alexa not using Apple music as default

  • 30 November 2019
  • 5 replies
  • 249 views

Badge

Im wandering if anyone can help.

 

I have Alexa fully setup on my beam and ive got Apple Music added as a service in the alexa app (it shows a green ‘linked’ under settings). Its set as the default for both music and stations. Obviously, Apple Music has been added as a service in the sonos app as well.

 

Normally things work fine and i can say “Alexa play xyz” and it will beginning playing from Apple Music. However, very regularly and out of the blue it will just start playing from Amazon music or one of my other music services thats been added in the alexa app. I double check and Apple music is still set as default and whats weird is if i say specifically “play xyz on Apple music” then it will work. 
 

Normally some combo of unlinking Apple music in Alexa and re-adding solves the issue but its happened today and nothing will resolve the problem. Also, its definitely not the case that im listening to obscure songs that Alexa cant find easily. Asking Alexa to play the number one album will still use a different service unless i specifically say to use apple music.

 

So frustrating. Please help.


5 replies

Badge

Ive been looking into this further and ive discovered the problem is only happening when telling Alexa to play an artist. 
 

I guess it must be a bug.

I’ve just gotten the Beam today and I’m having the same issue. Apple Music is set as default music service but whenever I call for music, unless I specifically say “...on Apple Music”, Alexa wants to play from my library or Amazon Music. 

Im having the same issue only with the beam as my play1 works fine and my beam plays amazon music and when i ask to play a song on apple music it say i need to link it which it is, im so frustrated with aleax and the beam i wish I didn’t buy it 

I’m having the same issue on a Sonos One. Apple Music is set as default service but music on Amazon Music by default. 

Userlevel 4
Badge +12

Hi everyone, sorry for the late response and thank you for reaching out.

To set a particular Music Service as default for Alexa; we would need to add the Music Service to both the Sonos app and the Alexa app.

Once added, go to the Alexa app and set the desired Music Service as default.

Menu > Settings > Alexa Preferences > Music & Media > Default Music Service > choose the Music Service you want.

It should play the service as default; in this case, it’s not.

I would recommend calling Amazon as to why Alexa plays other Music services when a default is already set.

If you have other concerns, feel free to reach out.

Reply