Answered

Sonos apps no longer display information when launching songs via Alexa

  • 15 April 2022
  • 6 replies
  • 106 views

Userlevel 2
Badge +3
  • Contributor III
  • 95 replies

Since today, my apps (iOS, Windows, 3rd party, ...) no longer show album art, title, artist, progress bar, etc. when I start songs by voice with Alexa. 


In these cases, the music is then streamed directly from https://d3rz60g1mtspwx.cloudfront.net and the info set is also reduced. Volume, Start, Stop all still possible, it is only nothing more displayed and strangely different streamed.

currentTrack:
absoluteAlbumArtUri: "https://d3rz60g1mtspwx.cloudfront.net/usw.
duration: 0
stationName: ""
trackUri: "https://d3rz60g1mtspwx.cloudfront.net/usw."
type: "track"
uri: "https://d3rz60g1mtspwx.cloudfront.net/usw.

If I start via Sonos app from Amazon Prime, it is as before and until yesterday and everything is displayed., it runs over the Sonos network and the info set is completely as always/before

currentTrack:
absoluteAlbumArtUri: "https://m.media-amazon.com/images/usw.
album: "On ne change pas"
albumArtUri: "/getaa?s=1&u=x-sonos-http%3acatalog%252ftracks%usw.
artist: "abc"
duration: 186
stationName: ""
title: "xyz"
trackUri: "x-sonos-http:catalog%2ftracks%usw.
type: "track
uri: "x-sonos-http:catalog%2ftracks%usw.

It is independent of the player.

A known problem? Solution available or in sight?

icon

Best answer by bockersjv 22 April 2022, 10:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Badge +17

Hi @THW,

 

I’ve tried replicating this on my own system, and I’m unable to reproduce this issue. 

Which service is being requested via voice? When I tried Spotify, Sonos Radio or Amazon Music, all of the metadata appeared correctly across the mobile, PC and Home Assistant apps.

Could you give me an example of a voice command that you’re giving to reproduce this issue that consistently displays no track info?

Userlevel 2
Badge +3

I’m using Amazon Prime Music. Same as before. With voice command “Alexa, play cxy”. And at the day of reporting the issues, it stopped deleivering/showing titel, altist, albumart, etc.

 

After starting it is showing “Playing from Amazon Alexa”. Sound is there, but then only the picture from first post without any information or picture.

 

cloudfront seems to belong to amazon as well. From which source is the music play from Amazon Music if you start with voice?

 

Amazon Alexa App is showing the information in parallel.

Badge +17

Thanks for confirming.

 

I’m still unable to reproduce this, and my colleagues aren’t able to either.

I suggest taking a diagnostic report after issuing a voice command, and getting in touch with our customer care team. They’ll be able to take a closer look at your system and investigate why the metadata isn’t appearing.

Userlevel 2
Badge +3

Thanks James.

Did so. Unfortunately until yet without any success (after a lot of removals, reboots, together with your colleague). 

I had now restart everything again. Did so. But it occurs directly even with only one online device.

He said, I should give the hotline a call outside the holiday. I will do so.

 

Here only for others, who are searching for the same: It is not only related to Amazon Music. Hit happens with Tunein as well. As soon the stream is started per voice, it comes (directly) to the device via a different way as when I start via app. And in this cases then without position, next, title, album, album art, etc.

Userlevel 2
Badge +3

Only as information, for those, who will have the same in the future. Wait and report to Sonos, but skip all the exercises from support (remove this and that and add this and that and ...) as the problem is outside your home (most probably at amazon).

 

3 days later and without any changes. The attributes get delivered to Sonos again and every client is showing the information as before.

 

absoluteAlbumArtUri: https://d3rz60g1mtspwx.cloudfront.net/etc
album: "foo"
albumArtUri: https://m.media-amazon.com/images/etc
artist: "bar"
duration: 196
stationName: ""
title: "lore ipsum"
trackUri: https://d3rz60g1mtspwx.cloudfront.net/etc
type: "track"
uri: "https://d3rz60g1mtspwx.cloudfro
 

Completely different, but now complete again, to the shown example above.

Userlevel 7
Badge +21

I raised this after the recent update

 

It appears to have been resolved now too.