Sonos, Alexa and Philips Hue, "it's not quite a routine"

  • 21 January 2019
  • 7 replies
  • 842 views

Badge
I can't find if the Alexa routines are supported already, or if it still doesn't work completely...

I have a Sonos Beam and two Sonos One as surround speaker.
I have also a Philips Hue Bridge with several bulbs.

I configured Alexa on my Beam and it works.
But I have made two routines and there I have a problem.

I have made the routines "Good Night" and "Good Morning".
"Good morning" turns on a scene.
"Good evening" should turn off all lights in the living room.

If I say "Alexa, good morning", the lights are turned on, according to the scene.

If I say "Alexa, good night", it responds with "good night, sleep tight", but the lights stay on....
I have added the living room to turn off as an action in the routine, but it didn't work.
I have also tried to add a n Alexa group of lights, but still no luck....

If I start the "Good night" routine in the Alexa app manually, it does work!

Can someone explain me how to solve this or tell me why a scene as trigger works, but turning off a lighting room doesn't?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Did you check your Alexa history in the Alexa App Settings for the voice instruction you gave and it’s interpretation ... sometimes Alexa may see/interpret things differently to the actual voice instruction you have entered into the routine. For example 'good night' is not the same as 'goodnight' or 'good knight', for example, so check the history and see how Alexa interpreted your message to make sure they are the same as the words typed in the routine.
Badge
Hi! Thank you for your reply, this was a unknown but nice trick to me.

But in the history things seem okay.
The text in the history is without capitals, but the "good morning" does work, so that seems to be no problem.
Can you confirm the routine that is not working is enabled ... see screenshot.
Badge
Yep, it is!



And the Lighting group action:

I wonder if 'goodnight' is an Alexa reserved word or something like that. If you create the routine again and change it to 'Alexa, time for bed' or something similar .. see if that works for you, perhaps?
Badge
That one I can try when I get home again!
Tnx for thinking with me!
Badge
Well, changing the routine name did the trick.
But now I get this message: "Audio actions are currently not supported on this device"

Right after that the lights will be turned off, so it works, but with a message.
But the lights are the only action in this routine....