Answered

Problems with Sonos Beam and Alexa integration

  • 19 July 2018
  • 2 replies
  • 4216 views

I've given this two attempts so far and am getting pretty frustrated with the process. Hoping this can shortcut me to a solution. :)

I just got my Sonos Beam. It's setup and working fine as a standalone speaker (I can play music on it through the Sonos App), and it's also working fine as a speaker for my TV (connected via HDMI-ARC). I also have an Amazon Echo in the same room.

I'm trying to power on/off my TV using Alexa. When I say, "Alexa, turn the TV on" she responds with, "Sorry, I didn't find a device named TV." From within the Alexa app, when I select "Add Device," the discovering devices wizard begins but always comes back with "No new devices found."

????

Thanks,
Chris
icon

Best answer by cpressley46 19 July 2018, 18:27

Ok, solved. My Echo was responding, never the Beam. In essence I had to blow away everything then re-enable everything and my Beam was able to discover the device. I followed the instructions here:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/beam-not-responding-to-spotify-skill-with-alexa-6809876

Also, had to enable 1-touch on my TCL Roku TV. Sonos support over the phone helped me with this part.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Your tv isn't a device that Alexa is going to find. When you're making your command to the tv, is the Beam responding or is your dot responding? You want to talk to the Beam in this case, so I would turn off the dot or relocate it to a different room. Alternatively, you could give your dot a different wake word.

You may also want to try targeting your command. "Alexa, turn on the tv in [room name]", where room name is the name you gave your beam in the Sonos setup. You shouldn't have to do this when speaking to the Beam directly though.

If none of that works, then the next step would be to disable the Sonos skill in the Alexa app, and then re-enable it and test again.

I also would confirm that you can make an Alexa music request with the Beam.
Ok, solved. My Echo was responding, never the Beam. In essence I had to blow away everything then re-enable everything and my Beam was able to discover the device. I followed the instructions here:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/beam-not-responding-to-spotify-skill-with-alexa-6809876

Also, had to enable 1-touch on my TCL Roku TV. Sonos support over the phone helped me with this part.