Problem with Alexa Integration - won't skip to next song

Userlevel 1

Hi All,


I’m resurrecting this question which was asked three years ago as it’s suddenly started happening after years of stability.


Problem Description:

  • Streaming via Alexa to Sonos.
  • Command “Alexa Skip” is registered by Amazon but the command is not executed on Sonos. At this point the system is pretty much in auto mode. It can be stopped and the volume can be changed but that’s about it.
  • Any streaming content has to be stopped before I can switch to a different channel / playlist from Amazon.
  • Album art is not shown on Sonos app.
  • “Next track” is greyed out on Sonos app.
  • Typically, this happens from the second track onward.



  • Stereo pair of Sonos 1 speakers linked with a Sonos Roam.
  • Running the most recent version of firmware.
  • Connectivity is via WiFi on a very stable network with strong signal strength.
  • WAN is bidirectional gigabit.


Any recommendations would be appreciated.


Best answer by D0bby 13 June 2023, 19:06

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

31 replies

I would perhaps first try removing and then reauthorising the Sonos Skill in the Alexa App. Check that the default music service (Amazon Music HD presumably) is logged in with the same Amazon account credentials in both the Alexa App and the Sonos App.

Note there are some limitations with the various available Amazon music services. See this summary link:

I’ve just tried the "Alexa, next/previous track” features and those are working okay here on Sonos speakers.. I’m using the Amazon Music Unlimited service. I’m also seeing the Album Art etc.

Userlevel 1

Thanks for the quick reply! I’ve re-authenticated my accounts and it appears to be workings.

Let’s see how things work over the next day or so.

Much appreciated.

Userlevel 1

Ugh… the issue appears to be back. This is what I see on the SONOS app from the second track onward.

I’m going to give Tidal a try and see if it’s any different.



Userlevel 1

As an update… I’ve been testing this with Tidal and it does exactly the same thing. First track is great and then it just implodes. No image. Controls are greyed out. Voice commands are processed but cannot be executed.

I guess it’s time to open a case.

I’m having the same issue. Weirdly, it was fine until I spoke with SONOS about a true play issue?!  

it was all OK, but not Trueplay option (turns out I can’t have it with my setup) following conversations with Sonos, I reset all units, then this issue happened.  No album cover, skip, with volume control etc.


it’s as if the media server is lost or something. Disabling the skill and re-enabling works every time, however, for how long is a mystery as it always stops again.

Userlevel 1

How interesting. How do you disable Trueplay?

While it’s not confidence inspiring at least it’s consistent across all of my SONOS devices (stereo pairs, individual players etc.) as well as different music services (Amazon and Tidal). Once the first song has played to completion, I lose any functionality (album art, voice control to skip or change stream, controls via the app - other than stopping).

Userlevel 1

Having the same issue on my Sonos Rome and five stereopair. Everything is up-to-date and I also have the added issue of not being able to go back to the previous track on any of my speakers, not just the two mentioned above. I am using Apple Music as my preferred music system. I have followed the troubleshooting article about adding/removing Alexa, linking/and linking the account, authorising authorising your devices et cetera. Nothing seems to make a difference. I am also running this latest firmware on all devices and Sonos products.

How’s that call coming along?!  I might have to go onto their chat function soon.  It’s driving me mad.


FYI. If you say “Alexa, pause” then say “Alexa next song” it works… WTF…. It’s not ideal, but it’s a work around and possibly an insight into the cause.

Userlevel 1

I've also made a discovery today. If I use Amazon music as my service, the next and previous work fine, but no such joy with Apple Music I fear. I'm not signing up to prime music purely so I can skip tracks. I still can't skip to a previous track though on either Amazon music or Apple Music services. Haven't tried Spotify, but that might be my next call.

Userlevel 1

Okay, so, this is a really interesting issue. Next and previous will work on Amazon music on my roam, but if I try using the previous command on any speaker other than the Rome, and with any music service, it does not work. I'm pretty sure you should be able to skip back to a previous track when you've just asked the device to play something by a certain artist. I can also replicate the issue where  if you repeat the device name and then issue the command again, it will work. So, for example, if you say "Alexa" then pause, then say  "Alexa next," this will skip to the next track. Doesn't work for previous though. I get a message that says I cannot do this on this stream.  Curiouser and curiouser 

Userlevel 2

same issue since a few days…


maybe a BUG? Or is someone currently running Amazon Music with Alexa without any problems?

Looks like it’s solved for me.  You guys?

Userlevel 1

Not unless there has been some sort of update in the last 12 hours or on Apple Music at least. Particularly on the roam 

Looks like it’s solved for me.  You guys?

It’s not solved for me, did you something extra to get it work again. After the start of the second track, nothing of the music control is working at all.

Userlevel 2

same issue

Same issue for me with Amazon Music when I play via Alexa. If I start playing from within the Sonos app (iPhone with latest iOS), all works as expected. Also, “Now Playing” correctly updates if I tell Alexa “next” or “previous”; it’s only when I press the next button in the Sonos app or when the playlist advances automatically when the current song ends that “Now Playing” breaks. Telling Alexa to “pause” followed by “play” restores the song to “Now Playing”. I’ve reset the Sonos app and disabled/re-enabled the Sonos skill in the Alexa app many times to no avail. Not sure when this broke, but it had been working as I always use the app to skip songs…Also, I’m seeing this issue with all of my Sonos speakers (Arc and Ones).

Exactly the same issue here. First spotted it with an Apple Music playlist so will now try Amazon Music to see if that works ok as it has for others. Shame as I prefer the Apple playlists but this lack of skip and the Sonos app greyed out is a real pain in the backside. 

Userlevel 2


Hi @cskardon 

Welcome to the Sonos Community!

We are aware of an issue whereby music from certain services (Amazon Music Prime, Amazon Music Unlimited, Deezer, or Spotify) does not show the correct metadata when initiated by a third-party app or Alexa. We are investigating, but have no ETA for a resolution.

In the meantime, please initiate playback from the Sonos app, or play via AirPlay, to avoid the issue.


Userlevel 4
Badge +2

I am having the exact same issue as well. I’ve already completely removed Sonos from the Alexa app and disable/enable the skill. Changed room names and just about all other ts steps I can think of. 

We've been experiencing this issue for a few weeks now. Normally happens when we ask Alexa to play the top tracks of an artist (could be coincidence). I haven't checked the Sonos app when the first song is playing, but when Alexa won't skip the track I can see everything is greyed out in the app and I just have an "End session" option. You can't swipe (left to right) over the buttons on the Sonos One to skip track either. This is using Amazon Music as the service. 

Yeah, so, issues is still there.  Initiating via the app solves the problem, however, tell that to my friends and family.  The A word is thrown around for different genres at a BBQ.


is anyone using the Lyd app on an Apple Watch? I can skip from there…

Ensure that your Sonos System is properly set up and connected to your network, Check for any software updates for your Sonos speakers and the Sonos app, Conform that the Alexa integration is properly enable in the Sonos App and reset the Alexa integration on Sonos.

Userlevel 2

its a Sonos issue and cant be fixed on ours side.


Officially confirmed by Corry P. here in this Forum.

Userlevel 2

it looks like everything is working normally.