No volume from speaker in an Alexa group

  • 18 September 2023
  • 3 replies

In the last couple of months I’ve had a really annoying issue with a Play 3 speaker when using Alexa. I have an L shaped kitchen with a Sonos 1 and 1SL stereo pair (called Dining Room) and a Play 3 (Playroom). These speakers are in an Alexa group called Kitchen and until recently this setup worked well.

A couple of months ago sound stopped playing from the Play 3 when requested via Alexa (Alexa play music in the kitchen), I can see the speakers are grouped in Sonos app and the app thinks it is playing, but sound can only be heard on the One / One SL pair. Removing and readding the play 3 doesn’t resolve.

Playback is fine via the Sonos app and playing music from Alexa just to the Play 3 also works fine, issue is only present when playing in the group. 

I’ve tried recreating the group in the Alexa app, resetting and renaming the Sonos speaker and nothing is fixing it. Has anyone else had this issue and know how to fix it?


Best answer by Jamie A 19 September 2023, 13:08

View original

3 replies

Thank you, issue still persists after 2 conversations with Sonos support. They initially fixed it by re-adding Apple Music and restarting all speakers but it reoccurred a few days later. There seems to be some issue with Apple Music, Sonos and Alexa groups. I’ve switched to Amazon music (which I realised a few days back wasn’t affected) from Alexa for the time being as a workaround when I want to use voice control.

Userlevel 7


Just a shot in the dark…try changing your request to “Alexa play music ON kitchen”. I had a similar issue with an Era 300 stereo pair called “Extra”. I had to change my command from “….ON Extra” to “…IN Extra”. Just the opposite of your commands LOL 😂 


Userlevel 7
Badge +15

Hi @Mattyps, welcome to the Sonos Community!

As you seem able to recreate this issue, I would recommend submitting a diagnostics while this issue is occurring then reaching out to our support team for further troubleshooting assistance. They have the necessary tools available to assist you in resolving this issue and can look into your system with the diagnostics to see more detailed information.

I hope this helps!