No voice Assistant or microphone

  • 14 April 2024
  • 5 replies

Hi guys

got a problem with my Sonos One 2Gen. Had it set up and working fine till I disconnected it from the power. Moved it to another room now I have no voice assistant. which i used for switching lights on and off or playing music. I have removed the sonos app disabled Sonos skill in alexa deleted alexa app and re-enabled it the same with sonos app reactivated Alexa. but no joy.

I have also tried installing the other voice asssitants Google and Sonos and I keep getting the same message “make sure your mobile device is connected to WiFi” which it is. I have tried splitting wifi still from one channel to two no joy..

I then did a factory reset in desperation and started again re-named my speaker so that I could check if both the alexa app and spotify could find my speaker, which they did. I re-enable sonos skill in alexa checked the sonos app under settings/products defo connected to 2.4 ghz and microphone is switched off I tried connecting hardwired nothing. (but I cannot connect wirelessly when hard wired)

I can connect to my iPhone to my Sonos One via WiFi and play music via either iTunes or Spotify. so its not a wifi issue. I can connect my iMac which is in a totally different room via the 5ghz channel and play music from either spotify or iTunes on my Sonos One. But I cannot activate a voice assistant or the microphone.


What am I missing?.


Its got to be user error, but for the life in me I can’t figure it out


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +19

In your post you say “microphone is switched off”; if you mean that, turn it ON. It may be worth toggling it off/on a few times anyway, just to check. 

Userlevel 7
Badge +19

Maybe also enable Sonos voice and check with simple commands like volume up. 

Maybe also enable Sonos voice and check with simple commands like volume up. 

Thanks for the reply nik9669a, however my problem is that I can’t enable Sonos voice or any voice for that matter and ignorer to turn the microphone on my understanding is that you need to have a a voice activated assistant enabled. I’ve made sure I have the latest Sonos App and the latest Alexa App and my iPhone is running the latest IOS please see pics 

image 1

image 2 

image 3 


HI Guys well I found a solution to my problem and it appears to have come in the “New App’ so I’m probably the only one whose thankful for it 😀


However, I’m not sure if the app sorted the issue or more highlighted it but either way I’m back up and running with Alex and able to control all my light switches and plugs etc.


Having installed the new app on my phone, I removed the old one first and once installed i when to setup “voice assistant” and I got a message saying you need to select a country, so we know your language.  I therefore went into my profile on my Sonos Account to check country. It was listed as GB (Great Britain) I then selected the drop-down menu and found United Kingdom.


I selected United Kingdom then checked Language it was also set to GB. I therefore clicked the drop down menu and selected English. Once I had done this. I then went back to the app and tried again. Still I got the error message you need to select your country. So I went back to my profile to check it had saved, and it had. I therefore signed out of the app on my iPhone and began again signing in and joining and existing system. The app found both my speakers and connected to my network, after I entered the password. I then tried to add Voice assistant and “Hey Presto” away it went login into Amazon requiring my username and password and automatically activating the Sonos Skill in Alexa

Therefore, one happy Chappy