NEW APP PROBLEMS***Cannot add alexa as a voice assistant

I’ve removed every speaker and added back. Wiped cache and data from my phone, uninstalled and reinstalled both apps. Removed all sonos devices from my Amazon account on my desktop. What am I missing. 

When I try to add a voice assistant in the sonos app, after adding the skill back into alexa, the dial just spins. It will not link to my amazon account.

What have I not thought of?

12 replies

Same problem here, I cannot sign in with Alexa from the Sonos app, the dial just spins for ever


I ended up having to log into my account from an iPhone to set it up. Then when I went back into my app on Android, it worked. That's the only work around I can figure for right now. Apparently it's just an Android problem

Worked as well using an iPad to set it up….

Very impractical…


Thanks for the tip!


Just bought Era 100 and have spent 4 hours+ on the worst, most frustrating set up I’ve ever experience.

And I still cannot sign into Amazon via the Sonos app to active Alexa.

I have hard reset the device three times, checked all the forums, disabled then re-enabled the Sonos skill in Alexa, deleted all Amazon apps and reinstalled, reset my phone several times, tried the device in different rooms. 

NOTHING works. This has been a totally miserable experience and, as I bought this speaker for smart home integration as much as music, I’m strongly considering returning it.

Meanwhile, the Era 300s I bought two weeks ago function perfectly well with Alexa. It makes no sense. I blame the new app rollout.

I would honestly give them a few days to correct the issue as I’m sure they know about it. It was all over my feed. I haven’t had any issues up until this new app rollout. But try using an iphone or apple device to set it up if you aren’t already. 

Userlevel 1

having the same issue. can’t add it:



I’m having the same problem. Trying it on another device yielded the same result. I can’t add voice assistance to any dev devices.

Userlevel 1

i wonder why this is not fixed yet. seems like a very basic and essential feature 

Userlevel 3
Badge +2

This was the chat I had with support earlier.

I The current Alexa issue is known at the moment due to the time and date not yet being fully integrated in the new Sonos app.

For more information on the missing added feature being added back in the new Sonos app, please check this link:
( this issue isn’t in this article yet tho )

I can’t get the Alexa set up to complete and I’m using an iPhone / iPad / Mac…. Interested to see on here that people are having success using an iPhone but it just won’t work for me at all. I get to the point of logging into Amazon then I get an error and the process fails. Followed all the suggestions, logged out and removed other Amazon apps, re-started the phone. Copied the URL to different browsers, nothing works. I now have 2 Sonos One speakers and a Beam Gen 2 with no Alexa on them. Do I scrap these and go back to using Echo devices? Lot of money for something that doesn’t do what is advertised and clearly not fit for purpose.

I had similar issues 3 months ago and got around this by copying the URL into Firefox and completing the set up there, but this now longer works. Its appalling that Sonos has been aware of this problem for so long and not only have they not fixed it, they have made it WORSE!  I have worked in IT for more than 30 years with a large Global company you will know if I named it, and if our code deployments were this buggy and useless, we’d be paying out in penalties and losing customers all over the place. Sonos need to prioritise the basics and stop mucking about with the pretty app interface. It’s no good if it looks nice but there’s nothing worth a damn under the surface and you’re pissing off all your customers because they can’t get the full benefit of the products they have paid hard earned money for. I’m really regretting moving to Sonos from Bose, and rather than my speakers being the source of pride and indication of sophistication and discerning taste they should be, they are a constant embarrassment that I would never in good conscience recommend to a friend.

Userlevel 1

Why is this not fixed yet? It's a basic and core functionality of the product, heck i bought me era100 because of this.


I even tried to enable Sonos voice but that too isn't working

Just received Move 2 and had the same issue with not being able to add voice assistant. I'm on Android, specifically Samsung S22. I found something on another forum about uninstalling Amazon Shopping, then attempting to link Alexa and it did work. I then reinstalled Amazon Shopping. Clearly the Sonos app and Amazon Shopping app have a conflict involved. Hope this helps others.


I also tested leaving Amazon Shopping on the device and disabled  'Open Supported Links', which did not solve the problem.