my Sonos One’s mic wont work on new Three 5g router

  • 6 June 2023
  • 3 replies
  • 84 views

I have managed to connect my Sonos One (2nd gen) to my new Three 5g router and I can control it from my phone however the mic on the Sonos is disabled so I can’t use Alexa. Any ideas please as it’s driving me crazy!

so far I have:

  • Tried the button on top of speaker
  • tried to enable the mic on the app
  • rebooted router and rebooted Sonos
  • reset Sonos and re-added it
  • tried to use Ethernet cable but the router can’t seem to see anything plugged in via Ethernet 
  • Disabled and reenabled the sonos Amazon Alexa skill 
  • split the 5g router to  2.4ghz and 5g via Three router  in router settings 

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +18

Hi @Mamamoo 

Welcome to the Sonos Community!

If you factory reset your Sonos One, you would have had to add a Voice Assistant to it afterwards before you would be able to turn on the microphone. I recommend that you do not repeat the reset.

I don’t understand why thing went wrong in the first place, however - a change of router certainly shouldn’t have disabled Alexa.

I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

It won’t allow me to add voice assistant. I already tried that.

 

also already spoke to Sonos and sent diagnostics to them. Their final word is Sonos doesn’t support 5g wifi 

Userlevel 7
Badge +18

Hi @Mamamoo 

Unfortunately, they are not wrong - we don’t support the use of LTE (mobile network) routers. Usually, the reason we don’t support them is because outside factors (like the weather) can affect the reliability of the connection - which mainly affects streaming - but there may well be other connection issues due to the use of LTE that could prevent services like Alexa from working properly. If Alexa worked fine right up until the moment you installed a new router, and then immediately stopped, it is fairly damning of the router and it’s connection method, unfortunately. I found this out only after consulting with a colleague, hence my earlier statement.

Note - if a voice service is not active, the microphone cannot be enabled. I suspect Alexa is trying and failing to get a cloud connection, and therefore the microphone never turns on.

If you were to take your phone and speaker to a friend’s home and connect it to their (non-LTE) WiFi and Alexa were to immediately start working again, that would be some fairly definite proof for you that the LTE connection is the problem.