Microphone Sensitivity on Sonos Arc


Userlevel 2

Hi all,

I recently enabled Alexa on my Sonos Arc and we are having awful problems with the Arc “stealing” the Alexa response.

We have a large open plan living space and Echo devices in the dining area, kitchen, snug and hallway, the Sonos is the AV system in the living area.  Before adding the Sonos system, the Echos were VERY good at working out which speaker was being addressed, you could be standing exactly between two Echos but if you turned your head towards one it would work out that was the one being addressed.  So if you were standing in the kitchen area and said “Alexa play the radio” it would only play in the Kitchen.  Amazing.

Since adding the Sonos Arc to Alexa system the Arc now ‘steals’ every response no matter where you are standing in the room.  Weirdly even if you specifically say the speaker like “Alexa play music in the kitchen” the Arc still steals the response and will start playing.  It’s like the two systems don’t talk to each other, if I’m standing in the kitchen and say “Alexa play music” the kitchen echo will start saying “ok here is a playlist you might - ” and get cut off as the Sonos starts playing in the living area.  
 

At first I thought it was a bug with Alexa but my wife worked out that if you whisper to the Echos up close (so the Sonos has no chance of hearing) then it works as expected, so it is definitely the Sonos microphone being over sensitive. 
 

We’ve had to disable Alexa on the Sonos now because it’s so annoying. 
 

TL;DR: the microphone sensitivity needs to be adjustable for the Sonos speakers otherwise it’s essentially useless in an open plan space. 
 

Question: is there a way to disable Alexa voice assistant and/or microphone but still use the Sonos to play music from Alexa by commanding it from another speaker like “Alexa play music on the living room Sonos”?  


5 replies

Userlevel 6
Badge +11

I have also notice similar recently, Sonos devices seem to respond, even though they are in a different room, eg trying to set a timer on Kitchen Echo, but a Sonos device hears the request in another room, and sets the timer in that room.

Amazon call this “Echo Spatial Perception” or ESP, and the best device is supposed to respond. I’m assume they all hear something, and they decide themselves which one should respond, but for some reason this is not working in all cases.

Maybe something similar to ‘True Play’ is required during setup, ‘True Listen’ ? 😀

 

You can do a number of things here. See below for the various options…

  • You can toggle off the mic on any of your devices including the Arc - tap the speech bubble on the Arc near the mic LED to toggle the mic on/off.
  • You can give your voice assistant a different wake word on your Amazon echo devices (See the device properties in the Amazon Alexa App).
  • You can configure your Sonos devices to be controlled by ‘Alexa’ using ‘Amazon Alexa enabled/controlled Groups’ - this is slightly more complex but it allows a lot of different playback customisation and automatic grouping/ungrounding of speakers. See LINK
  • You could use Sonos voice control (Sonos’ own voice assistant) instead, or aswell as Alexa on your Sonos Arc - see LINK
Userlevel 7
Badge +12

I use different wake words on my echo devices and keep the Alexa wake word on the Sonos Speakers 

this can help however I have disabled voice assistant on the arc as tv dialogue can sometimes activate it 

no big deal as I have a fire tv cube in the same room 

Userlevel 7
Badge +20

It is the amazon cloud that determines which device has heard the clearest voice command but Sonos do control the Sonos Mic Sensitivity.

How have you setup your Alexa groups for your echo devices and the Arc?  Perhaps, a screen shot of the Alexa App if you are comfortable sharing?

Userlevel 7
Badge +20

Just to add one other point, since voice control with Alexa was introduced, there have been a fairly equal number of posts asking for the sensitivity to be increased against those asking for it to be decreased - so @craigski suggestion for some form of tuning or app control is probably the way forward.

Reply