Issue enabling the sonos skill within Alexa app


Badge
Having some issue enabling the skill. It asks me to link accounts... So I do. Log into sonos, then I log into Amazon and when it asks to link them I hit continue.

Then nothing.

No success or fail screen, it just takes me directly back to the alexa app home screen. I'm hoping I'm doing seething wrong. (worth noting my controller app and sonos speakers are up to date). Any ideas?

I'm in the UK if that makes any difference.

10 replies

Userlevel 2
Badge +1
I encounter the same issue,what I found out, when you add the Sonos skill on the alexa app, make sure that your Sonos app is updated already to 8.0. if not, the Sonos skill will not be linked.

My problem, initially, I was not able to update my Sonos app on my phone, so I have to delete the Sonos app and re-install it, and after it was updated to Sonos app 8.0, I was able to enable the Sonos skill on my alexa app.

hope this help
Badge
I had the same issue - also in the UK - using the latest Alexa and Sonos apps on my Samsung Tab S2 running Android 6.0.1.

When I entered the Amazon username and password I was dropped back to the Alexa home screen. Very occasionally a blank screen would be returned with a single line of text - I didn't record it I'm sorry to say - I seem to recall the word "error" followed by three parameters listed in brackets - at least that is what I remember. But it too reverted to the Alexa home screen.

I attempted multiple times, including uninstalling and reinstalling the Alexa app, restarting the Tab S2 and restarting the echo dot that I have connected. All attempts to enable the Sonos skill ended up with the same results. I did not try to uninstall the Sonos app.

I moved to a different device, running Android 7.0.1 that had the latest Sonos app installed, but never had the Alexa app installed. When I installed the Alexa app and connected to my Echo then enabling the Sonos skill using the Alexa app on that device worked as described, I was then able to discover the Sonos speakers in my system.

Moving back to the Tab S2, the Alexa app running on there had picked up the fact the Sonos skill was enabled and listed the Sonos speakers.

I am at a loss to explain why it worked on one device not the other - the only difference I saw is that the Tab S2 is a shared device whereas the other device is not. When the Alexa app got to the Amazon sign-in on the Tab S2 it had preloaded my wife's username, but no combination of changing it to my Amazon account username (where the echo dot is registered on Amazon) or clearing the defaults from the browser to stop the Alexa app preloading my wife's username seemed to make a difference. It is my Amazon music account that is enabled via the Sonos app not my wife's.

Bit of a rambling description - without a clear reason for the cause of the problem, but perhaps something else to try instead.
Badge
Unfortunately I updated both the Controller App to 8.0 and the speakers to the latest available firmware before starting the process.

However this morning i have restarted all Sonos speakers as well as all Echo devices in my house. I then ran the process via the website https://alexa.amazon.co.uk/ rather than the Alexa app on my phone and it appears to have worked.

Thanks
Badge
Ah - you reminded me - I didn't mention that I too tried to enable the Sonos skill from the Amazon UK website like you described and it too failed.

I didn't restart the Sonos speakers though.

Good to hear that you resolved your problem too 🙂
Badge
Appreciate the help, cheers.
Userlevel 2
Similar issues with Alexa app, but going via website worked for me. Didnt restart the speakers beforehand
Mine will only play a sample of each song??? Also can I play the radio??
I had the same issue where I tried repeatedly but couldn't link the Sonos and Amazon accounts on my 1Plus3 phone eventually I tried it on my wife's Moto G and it worked ok.
Unfortunately having got it working I found it wasn't actually worth the effort.
I'm surprised that after all the time that this has been in dev it doesn't do more the basic controls announced yesterday
Same issue here. What I noticed is that when trying to link then after logging into sonos it takes me to the amazon.com site, not the amazon.co.uk one in order to authenticate. Like others I get chucked back to the alexa app, without the skill installed. I'll try via the website, but for me the app doesn't work - on both iOS & Android.

Update: going via the website works fine, but not via the app. Website did link me to amazon.com to authenticate, but it worked first time.
I am in UK: when I enable the Sonos Alexa skill it tries to link to Amazon.us.com not Amazon.co.uk where my amazon account is.
Ok using the browzer to set up Sonos skill on pc works, setup doesnt work on Android

Reply