Question

"I can change the playback mode only when music is playing" Sonos One problem


My Sonos One is driving me crazy. I can use it with Alexa to play music in other rooms. But when I ask it to stop the music, or change the volume, or play a different song, Alexa says: "I can change the playback mode only when music is playing." The only way to adjust the music in the other room is to use the Sonos App.

Has anybody else encountered a fix? I have five Amazon echos or dots, and five Sonos boxes of various types. I have taken the whole system down and back up, and restarted the Sonos Skill in Alexa and recognized all devices. Nothing so far has changed this behavior.

I've owned Sonos' for 13 years and never had these kind of problems with set up. It feels like I'm dealing with a Microsoft product.

11 replies

Go into the Alexa app and make sure there are no duplicate names for your Smart devices. If there are, give them unique names.
I've already tried that. And repeatedly disabling skill and enabling sonos skill in Alexa app. And reconnected all Sonos devices.
Getting the same issue, keeps repeating the same message, when I ask to stop music. I also notice that within the Alexa App, the Sonos one is seen as two devices? It seems the Sonos speaker is seen as separate device to the Alexa function. Not good!
Also, what is even worse - when I tried to set a reminder it said it's not supported on this device! So I may as well take it back to swap for an old sonos play one and get another dot.
Userlevel 3
Badge +3
Within the Sonos app (Android or iOS only), select settings and then select the Sonos 1. Disable and then Enable Voice control and see if that works.
Thanks, but I actually took that damn thing back today and swapped for a play 1 and gonna get another dot. I think seeing as a lot of people are having issues with important features, sonos are gonna have to get their finger out pretty quick!
Userlevel 6
Badge +3
For this sort of issue, the best steps are to start with above, disabling and enabling. Also going into the Sonos app to toggle voice there is a great way to go.

If you're still having trouble, I recommend giving us a call on our support line and working with a technician. We can help sort things out.
Thanks Ryan, will do. Also having trouble with voice control not stopping music on play 1 via an amazon dot. Works occasionally but not most of the time which is a bit frustrating. Will definitely give you a call. Thanks :-)
Deleting the Amazon app and redownloading it for whatever reason cleared the issue up for me!

Solution discovered by jlee here: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/error-discovering-devices-in-alexa-app-6792666/index1.html#post16164290
Badge
I had this exact issue and as of this morning it was working much better. A tech support person indicated that there was a "short outage" that affected the Alexa voice commands. Who knows..but it all of a sudden started working without any intervention on my part-other than unplugging and re-plugging the speaker
I had the same issues and it was driving me insane.

After a call with the support team at Sonos we went through all of the above but actually found out the issue was a setting on my amazon account

He said I would need a computer to access certain settings but you can do this on an iPhone by requesting a desktop version of the site.

Once you do that go to settings, content and devices and check all is ok there and you can see your devices. Then click settings then see the country settings section. My has the country as “unknown”

So for me the issue was that I didn’t set a country! Once I set that then asked Alexa to play the radio it did! And through the Alexa app my Sonos turned from offline to online.

All sorted! Hope that helps.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)