Answered

I always have to ask Alexa twice

  • 10 January 2021
  • 7 replies
  • 138 views

We all know that the integration of smart assistants in Sonos is botched, but hopefully someone can explain my most recent problem. 
 

everytime I ask Alexa on my Sonos Ones or my Sonos move to play something she replies correctly with “playing xxx from Spotify” and then nothing. If I ask again it works. I’ve tried resetting the voice assistant and tried different music providers with no change. It’s really strange, whatever happens to the first command I wonder?

 

 Anyone else experiencing this?

 

 

icon

Best answer by UKMedia 24 January 2021, 09:36

Ah. I missed that hyperlink. Did you mean this advice:

The ONLY way to resolve this issue is to reboot your network in this order:

  • Router
  • Any wired Network devices or switches;
  • Any other wired devices;
  • All other Wi-Fi devices (Turning Wi-Fi off and on again on each device would also work)

If so, when you say “reboot” do you mean to power down the items in that order then power them up in that order or reboot them one by one with the other items of kit still powered on?

Either approach will work, although the latter option is the most practical in my opinion. Personally, I recommend reserving the IP addresses in your router first, as these devices need to be rebooted again for the new addresses to take effect.

View original

7 replies

I haven’t experienced the issues mentioned and currently have not seen that problem with Spotify, or Alexa, but perhaps try these few steps to ‘hopefully’ fix your issue...

  1. Remove the Sonos ‘skill’ in the Amazon Alexa App skills section.
  2. Remove the Alexa Assistant from your speaker(s) in the Sonos App under "Settings/Services & Voice/Amazon Alexa"
  3. Important step - log into your Amazon account online and ‘deregister’ all your Sonos devices under the “Manage Content & Devices” section of your account (devices tab). The link to devices is something similar to the URL shown below, but you ‘may’ need to adjust the link to point to your own country/account: https://www.amazon.co.uk/hz/mycd/digital-console/alldevices
  4. Unlink and re-link Spotify to the Amazon account in the ‘Settings/Music’ area of the Amazon Alexa App and ensure it is set as the Alexa default music service.

Then go back to the Sonos App and start by adding your Alexa voice assistant to your speaker and follow the on-screen instructions and all being well, Alexa should then (hopefully) work fine.

Userlevel 7
Badge +20

We all know that the integration of smart assistants in Sonos is botched, but hopefully someone can explain my most recent problem. 
 

everytime I ask Alexa on my Sonos Ones or my Sonos move to play something she replies correctly with “playing xxx from Spotify” and then nothing. If I ask again it works. I’ve tried resetting the voice assistant and tried different music providers with no change. It’s really strange, whatever happens to the first command I wonder?

 

 Anyone else experiencing this?

 

 

I have experienced of this, normally the first command in the morning.  The interesting thing is that after asking twice for the first track, if I then ask for a different song it works the first time.  I tried loads of different things to resolve.  It would appear to fix the issue then after a few days/weeks it would return.  In the end I think it was resolved by the steps I listed within this article.

I have exacty the same issue. As mentioned before, after you’ve asked Alexa twice to play the first song, she then gets into a groove and reacts first time to future requests. I’ve not found a way to solve this if anyone else has?

As others have been posting, this only started happening with the big app update in 2020

Userlevel 7
Badge +20

I have exacty the same issue. As mentioned before, after you’ve asked Alexa twice to play the first song, she then gets into a groove and reacts first time to future requests. I’ve not found a way to solve this if anyone else has?

As others have been posting, this only started happening with the big app update in 2020

Did you try my suggestion in my previous post?

Ah. I missed that hyperlink. Did you mean this advice:

The ONLY way to resolve this issue is to reboot your network in this order:

  • Router
  • Any wired Network devices or switches;
  • Any other wired devices;
  • All other Wi-Fi devices (Turning Wi-Fi off and on again on each device would also work)

If so, when you say “reboot” do you mean to power down the items in that order then power them up in that order or reboot them one by one with the other items of kit still powered on?

Userlevel 7
Badge +20

Ah. I missed that hyperlink. Did you mean this advice:

The ONLY way to resolve this issue is to reboot your network in this order:

  • Router
  • Any wired Network devices or switches;
  • Any other wired devices;
  • All other Wi-Fi devices (Turning Wi-Fi off and on again on each device would also work)

If so, when you say “reboot” do you mean to power down the items in that order then power them up in that order or reboot them one by one with the other items of kit still powered on?

Either approach will work, although the latter option is the most practical in my opinion. Personally, I recommend reserving the IP addresses in your router first, as these devices need to be rebooted again for the new addresses to take effect.

I’ve followed those instructions through. I wasn’t quite sure what was meant by reserving the IP addresses. In the router controls there was an option for ‘Always use this IP address’ and this was turned to ‘yes’.

Alexa is now responding to song requests the first time. I’ll keep an eye on things as after a time of period, sometimes the system reverts back to needing to ask twice.

Thanks for your help so far UKMedia

Reply