How to play from pandora using sonos one and alexa?

  • 29 October 2017
  • 5 replies

My Sonos account is linked to my Pandora account and I can play Pandora stations using the Sonos app on my phone. But if I ask Alexa to "Play whatever station on pandora" she responds "I didn't find your pandora account. You can link your account using the Alexa app." But if I open the Alexa app and go to Music, Video, & Books and then click pandora it says "App Support Unavailable". What am I missing?

Best answer by leskoonk 31 October 2017, 21:41

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Same problem, close to giving up
Here's what caused it for me:

I purchased my Echo on my daughter's account and shipped it to myself (she has Prime). Amazon apparently pre-registers the device to the account that purchased it. And this caused the problem.

I registered it to my own account and set it up and everything seemed fine, except the Pandora problem (same as reported here).

I had to have my daughter de-register the device. Then I logged out of the Alexa app, and logged back in and then re-did the entire setup.

This time everything worked as expected.

So: maybe try de-registering the device and then re-do the setup.

I hope this helps.

txs larry. spent an hour with sonos tech rep today. they were great. you may be on to something. i bought my sonos one from a non amazon source so it wouldnt have been pre-registered. for me, what seemed to have caused the conflict was that i had the amazon shopping app open (or logged into) which had differing log in credentials from the alexa authorization that i registered the device with. once i removed the app, i was able to get everything working. so for those running into this, i suggest at least logging off from all amazon related apps, then see if you can get alexa to work.
I fixed this by going around the usual way of adding an account. Instead of going to the menu, music video and books then pandora. Go to menu, settings, tap music and media under accounts. You'll see your possible music services there, then add it that way.
Thanks to all -- All of the above worked but you have to make sure to click on link at bottom of the Music and Media Settings page that reads: CHOOSE MUSIC DEFAULT SERVICES and select Pandora under Default Station Services.