Answered

Fixing setting Up Voice Assistant

  • 20 January 2024
  • 5 replies
  • 117 views

I am Trying to set Up my Alexa on my sonos one. o i went through the steps and as soon a i try adding the sono skill and need to log in into my sonos account i get the message that i need to update my app which is up to date and then also that i need to register a speaker onto my account which is working fine through sonos app. When i log into my online account and check under my system Menu i get a mesage showing no devices registered. How do I get it to add then. Also tried adding Google assistant and exactly the same problem.

 

icon

Best answer by Sotiris C. 22 January 2024, 13:39

View original

5 replies

Userlevel 6
Badge +14

Hello @Tridon01, welcome to Sonos Community!

I am sorry to hear you are having problems adding Amazon Alexa on your Sonos system.

I had a look on your account and I can see a Sonos One (Gen2) registered there so I’m not sure why you are not seeing any through our website.

A couple things I would suggest:

  • Confirm that you are using the same email address as the one used for our Community, for your Sonos Account.
  • Make sure you have the latest version of the Sonos App, you can download it from here.
  • Have a look at our Support Article: Set up Amazon Alexa with a voice-enabled Sonos speaker.
  • If possible, use a different controller (smartphone/tablet) and try the above.

If you are still experiencing issues adding Amazon Alexa to your Sonos, I recommend reaching out to our Support via a call, as they can guide you through the process and provide advice specific to your system and what it reports.

I hope this helps.

I am having the exact same issue since a few weeks. I already have followed all the steps indicated here, but also reset everything by deregistering at my Amazon account, but unfortunately nothing has helped. Considering nothing has changed on my end, I feel like there is something wrong in the connection between Sonos and Amazon.

I have also called support, they have looked at a diagnostics report, but so far they could not help me either in solving this issue.

Edit: Actually opening the Sonos website does correctly show my registered products, but trying to enable the Alexa Skill gives me the same error indicating that I have to register my speakers.

Over the last few days I had been able to enable the skill once or twice, but still starting Spotify through Alexa would not work. Usually after getting it to work one time, I would get the error again, when trying to enable the Sonos skill.

Yesterday everything started working again, so let’s see how long it will last. I’m pretty sure this is an issue with the communication between Sonos and Alexa, but probably nobody from Sonos will be able to confirm this.

I am having huge issues trying to add any voice assistant

 

 Make sure your mobile device is connected to WiFi is all I get

I would call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

 

Reply