echo dot and Sonos amp

  • 1 August 2023
  • 3 replies

Userlevel 4
Badge +13

I have an Echo Dot in my lounge and also a Sonos Amp connected to non Sonos speakers. I also have other Sonos speakers in other rooms. If I ask my Dot to play something on the Lounge Amp it always plays to my Kitchen Play 1! I can also ask it to play on my other Sonos speakers in other rooms which it will do. However if I ask it to play on my Lounge it always plays in the kitchen! Whatever process I try, I just can’t get it to play to my Amp despite following online instructions.

Help please. Thanks.



Best answer by Ken_Griffiths 1 August 2023, 14:15

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

In the Alexa app, take a look at the Alexa groups you have set up.  I’m guessing you have a ‘Kitchen’ group’ that has the Lounge Amp setup as default speaker.

As a last resort, you could remove the Sonos skill in Alexa, make sure are your Sonos speakers are removed from the device list, and setup the Sonos/Alexa integration again.

Move your echo dot in your Amazon Alexa Groups to control/enable the group that contains your Sonos Connect:Amp in both the second (audio ducking) and third (speaker) sections of the group and then that should sort it for you…see the ‘example’ screenshot of an Amazon Group in the Alexa App, which hopefully may also assist you.

Userlevel 4
Badge +13

Thanks so much Ken, really appreciated.