Answered

Did the new update break the preferred speaker function in smart home?

  • 31 January 2019
  • 3 replies
  • 307 views

Userlevel 1
Badge +1
Not sure if it is a coincidence. I have a pair of Play 5 set as preferred speaker in the living room group. "Play music" would start Spotify and play on the Sonos.

But since today Alexa responds with "something went wrong". When I set the Echo (Show) as default speaker it works again, switching back to Sonos (Play 5 and/or Beam) is will result in an error again.

I disabled and enabled the Sonos skill, no luck. Anyone else seeing this? Could it be the update, or is that only controller related? Any tips how to trouble shoot?
icon

Best answer by HvLee 31 January 2019, 21:59

Please let us know how you get on. Many thanks in advance.

Thanks for the prompt reply. I start to think it was more on the Echo side, this morning all my rooms with a Echo+Sonos picked up the way it was setup.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +19
Hello there. Thank you for raising this issue. The first step is indeed to open the Alexa App and remove the Sonos Skill and then re-Enable. As that did not work, please see this thread here. Failing all of that, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause. Please let us know how you get on. Many thanks in advance.
Userlevel 7
Badge +20
As the upgrade sometimes re-boots your Sonos devices, this may be down to duplicate IP Addresses. Can you please power down the following devices for 5 secs, allowing each to complete its boot cycle before proceeding to the next device:

- Router
- Any Network wired switch
- Any wired Sonos devices
- All other Sonos devices
- All other attached network devices

If this fixes the problem, I suggest you open the Settings page on your Router and reserve IP addresses for your Sonos devices - I personally use the range 192.168.0.240 and above for my Sonos devices.
Userlevel 1
Badge +1
Please let us know how you get on. Many thanks in advance.

Thanks for the prompt reply. I start to think it was more on the Echo side, this morning all my rooms with a Echo+Sonos picked up the way it was setup.