Answered

Connect Echo Flex to Sonos S2 Amp

  • 29 October 2023
  • 4 replies
  • 80 views

Badge +2

I have a housefull of Sonos products and even more Amazon Echo products, including an Echo Flex, the speakerless Echo device that one can use to hook up to anything with an RCA or mini plug input.

I want to plug it into my S2 amp which is connected to passive speakers so that I can have the convenience of saying “Alexa play music everywhere” or “Alexa play music on Sonos amp”.

I’ve got the Flex plugged in and added to the ‘everywhere’ group in Alexa and have set the S2 amp to Line in but get no music through my Sonos S2 connected speakers.  It plays everywhere else in the house through all of the Echo devices, so I need some help here.  Thought I’d come here first before I engaged Sonos tech support.

 

icon

Best answer by Kumar 29 October 2023, 19:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Have you set the Sonos amp line in to Autoplay via the app? Note that music via this route will not be in sync with that played directly via other Echo units directly.

Badge +2

Hi Kumar - the line in selection is set in the app.  Yesterday Sonos support got it to work by reinstalling the Alexa link in the Sonos app.  At this point, I can say “Alexa play music in Living Room” (where the S2 Amp & speakers are) and it will play.  However when I say “Alexa play music Everywhere”, where “Everywhere” is all Echo devices plus the S2 Amp, it will play music everywhere except the Sonos Amp.  Tech support directed me to engage Amazon about this.

What you say makes sense though, especially if I were to try to have my other 3 Sonos Zones in the Everywhere group which I haven’t explored yet.  

My passive speakers attached to 3 of my 4 Sonos zones are exellent (one zone is an S1 Play 5) and the Echo devices are, well, Echo devices with 1” speakers and such.  Hence why I want to do this.  

Thanks for your thoughts on this.  Work in progress.

Make sure that the everywhere group in the Alexa app includes the Flex. My set up has Echo devices wired to Sonos kit, and all Echos are in the Alexa app configured everywhere group. 

 Yesterday Sonos support got it to work by reinstalling the Alexa link in the Sonos app. 

If the Echo Flex is connected via wire to the Sonos amp, the quoted step is irrelevant to the issue you are facing of a voice command to the wired Flex not having music play on the wired to it Sonos amp. Remove the wire from the Flex and see that the Flex plays in response to the play everywhere command given to any Echo. Once that happens, any reason for Flex to not play when wired to the Sonos amp is in the line level settings for the Sonos amp, or in the volume level settings for the Flex or the Sonos amp. Or in the integrity of the wired connection.

Since I prefer Echo front ends, and my Sonos kit all has line in jacks, wired to Sonos Echo units work flawlessly, playing either singly or as a group in perfect sync, via voice command to any of the Echos. Or via the Spotify App on my phone.  And since some include the older generation Echo Shows that had line out jacks, I also get album art for what is playing, seen on the Show units.