Question

cant sign in to amazon when adding alexa


Userlevel 3

In the new app, I go all the way until it says signing in to Amazon. It stays there eternally. Tried everything. Deleted data, cache, restarted system, factory settings, etc. I can't pass that step to add Amazon Alexa to my speakers. 


100 replies

Userlevel 2
Badge

I have exactly the same. I’ve managed finally to get the ‘Sonos skill’ working in Alexa and it has found the Sonos speakers (two ERA 300s) but when I then go to add Alexa within the Sonos App, the ‘log in to your Amazon account’ cycles endlessly. Very, very frustrating. Again, as with other bugs in the new app, this was all working perfectly before the update. 

I did have to change my Amazon account password around the same time and wondered if this was part of the issue, but I think it is the new app now just not loading the Amazon log-in.

I’m on the Android app on a Samsung phone. 

Userlevel 3

Exactly same issue send device 

Same issue…. 🤦🏼‍♂️

Exactly the very same issue here.

Userlevel 2
Badge +4

Same here with a new roam on the new app.

same issue here. it also won’t let you manage your system with the old app (which i kept on my ipad so i can set sleep timers) forcing you to upgrade. the worst “upgrade” ever

update: it worked from an iphone, but does not work on android (samsung). clearly it is an app issue

Yep, same issue here. 

Userlevel 2
Badge

So, I spent an hour with customer support yesterday and we went through all sorts of steps to see if it could be solved, but no luck. I pointed out there were plenty of people coming across the same issue in the forum. CS concluded (as we all assume) that it is the SONOS app. They said an update was due next week that should address the handshake between the app and Alexa. 🤞

Userlevel 2
Badge +4

@RustyPane Thank you for sharing that information.

Userlevel 2
Badge +4

Downgraded to 16.1 which solves all the other issues for me but unfortunately not this one. When I click on add a voice assistant I get App Update Needed. If anyone knows a workaround please advise. Else I guess I’m waiting for the new app fix then will deploy it via my wife’s phone (she does not use her app so won’t notice getting the dodgy upgrade!) and stay on 16.1 myself until they fix the other defects.

Same issue. Just bougt a Sonos Arc soundbar and I cant signing in Amazon. Frustrating. This is is no a cheap product, but the service sucks.

same issue using android on sony xperia, new sonos app, updated Move… very frustrating as worked fine till i swapped out my router. Network is fine just can add any services or find BBC radio stations

Having the same issue since the latest update. I have done a full factory reset on my system to no avail.

Same as others mentioned hangs indefinitely on the “singing in to amazon” pop-up on the android version of the app.
I extensively use the Alexa feature in that room for lights and heating, so have a very degraded service with the system right now.

Exactly the same problem. Any solutions yet Sonos????

 

When's the patch coming?

I had to download the Sonos S1 app on an apple device to get around this as issues exist with the 11.14 android release. I then had to get on the Alexa app → Go to My skills, disable sonos and re-enable it. The entire process was totally unnecessary and abysmal……………..Sonos needs to get the bug fixed on Sonos S1 for android Devices. Totally poor to have us all update to a version that clearly does not work properly. Also the UI experience on Sonos S1 application release is horrible. What the heck, the Sonos original UI far beats this crap!!!   

Problem still persists even after re enabling the Sonos skill

there is a new Sonos app update, but even after updating still can`t add alexa as voince assitant 

Same problem here. Samsung phone.

 

How is it possible Sonos managed to break every component of their service with this app and still don't have a fix? Do you even care about your products any more? Good Lord, I can't believe this multi thousand dollar audio setup I have has been completely ruined by a software update. 

Same problem. Google pixel. I've always found the Sonos a damned nuisance. Always buggy. Not good enough for a premium product.

Userlevel 2
Badge

So, I was told by customer support after hours of trouble shooting last week that this week's update would fix the issue, and it hasn't.

The fact it's working on IOS makes me think that perhaps SONOS think the phone we've bought is more important to the service we receive than the audio equipment we bought. 😡 

Same problem. Worked 1.5 weeks ago, not now. I have tried everything. Nothing works. Android

At least we are all in the same boat and we know it requires an app update to fix. Hopefully the more attention on this post the quicker the devs will get a fix out.

Userlevel 7
Badge +18

Hi @Nico Sener et al

Thanks for reporting this issue with adding Alexa. We are unable to reproduce this issue in our own testing - could some of you please re-attempt to add Alexa to your system, then when it fails, immediately submit a support diagnostic? Please don’t post the given numbers here on the forum, however - instead, please DM them to me, letting me know you were trying to add Alexa. Thank you for your assistance in this matter.

I just submitted the diagnostics, I have the same issue as everyone else, once you try and add Alexa as the voice control, it pops a new screen  that says “Signing into Amazon” and never updates or completes. This happens no matter what, after power off, factory reset, with the Sonos skill enabled/disabled in the Alexa app, and with the Sonos Voice Control enabled or disabled.

Reply