Answered

Beam/Alexa won't turn on/off TV

  • 17 August 2018
  • 8 replies
  • 7421 views

My new Sonos Beam is connected to my TCL TV with a HDMI Arc. I've then installed Amazon Alexa on my beam.

If my TV is turned on, and I say :
1. "Alexa, turn off TV", she responds with "OK" and IT WORKS
2. "Alexa, turn on TV", she responds with "OK" and IT WORKS
3. If I wait 2-3 minutes with my TV turned off, and then tries to turn it back on with Alexa, she responds "OK" but nothing happens. I then have to turn the TV on manually.

She responds perfectly with any other commands I give her, regarding Spotify etc. But there seems to be some kind of problem between Sonos beam/Alexa and my TCL TV.

Does anyone know about this problem, and a possible solution?

Greetings,
Alexander
icon

Best answer by DSJ7 22 August 2018, 18:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

I don’t know the TV, but is there some kind of power saving (eco) settings somewhere within the TV settings? Perhaps that is sending the HDMI ARC port to sleep after a period of time has elapsed.
I have found that if you use the room name in front of tv it will turn tv on or off. e.i. Alexa turn off Lounge TV or Alexa Turn on Lounge TV.
I am currently having the same issue. The beam will turn my 55” TCL Roku tv off but will not turn it back on. Alexa recognizes the tv when I ask her to turn it on because she says “ok” but then nothing happens.
I am currently having the same issue. The beam will turn my 55” TCL Roku tv off but will not turn it back on. Alexa recognizes the tv when I ask her to turn it on because she says “ok” but then nothing happens.

Unfortunately I'm still having the very same problem on my TCL Roku tv.. I've tried every solution I could find, but still not solved the problem. I'll let you know here, if I somehow manage to fix it 🙂
I found a fix last night. Enable 1-touch in the settings of the Roku tv. Disable the Sonos skill in the Alexa app and re-enable. Rediscover the device. This fixed my issue and the beam is operating how it should.
I’m having a similar problem. I have also added an echo spot. Tv turns on with command but will not turn off even though Alexa says ok after command. I’ve tried disabling Alexa and rediscovering devices etc. it still does not turn off. Has anyone had any joy with a solution.
Cheers
Adam
What if you don't have a Roku TV? Does this solution work with Apple TV?
This worked for me on my TCL Roku tv to simply enable 1 touch.