Answered

Alexa won’t respond to stop command

  • 28 October 2017
  • 14 replies
  • 43412 views

Badge
I successfully set up my echo dot to control my sonos speakers. It will play radio stations and change from radio to streamed music but it won’t respond to my command to stop playing. I have disabled and renabled the sonos skill and rebooted my echo dot. Any help would be appreciated.
icon

Best answer by Keith N 15 May 2018, 23:31

Hello everyone. Here is an article that goes over the commands that work best using the Sonos Skill on Alexa.

If you are still having troubles using voice commands, feel free to give our support technicians a call to troubleshoot this in real time over the phone.
View original

14 replies

I had this same problem and couldnt really get much help, but I did figure out a fix, at least for me.

My Sonos One was grouped in the Alexa app in a room, and because of this I had to say Alexa Stop playing on room-name , I moved the Sonos speaker out of the group and now I can just say Alexa Stop, Alexa Play, etc etc.
Try "Alexa, pause in (room name)" instead of stop.
Userlevel 5
Badge +2
Pause

Resume

Not stop.

I can’t find the link at the moment but acquainting yourself with Alexa commands will assist you in getting the best out of your system.
Stop works, but it conflicts with so many other Alexa commands, it is quirky. I found like BoB, that pause, resume, skip, previous are better than stop, play, next, back. Ymmv.
To fix this issue on the Sonos One:

1) Open the Sonos app, go to More - Room Settings - Your Room - Amazon Alexa and select Deregister
2) Open the Alexa app, go to devices, find your speaker and select Deregister
3) Refresh the devices list in the Alexa app by pulling down on the list. Your device will still be listed as a speaker rather than an Alexa device, now delete it again. Repeat these steps until your device no longer shows in the Alexa Devices list.
4) In the Alexa app go to Skills and remove the Sonos skill.

Your system is no longer linked to Alexa and can be reset up.

1) In Alexa app add the Sonos skill and login to your account. It will prompt you to discover devices - do this. Now you should be able to control the speaker through the Alexa app by saying “Alexa play Spotify in kitchen” (where kitchen is your room or speaker name)
2) Open the Sonos app and add the Alexa voice service.

You can now control music just by saying “Alexa stop” instead of giving the room or speaker name.
Userlevel 7
Badge +20
If you check Settings-History within the Alexa app, is it correctly hearing Stop?
thank you - was so frustrated!!!
I am having the same issue with my alexa tap and stopping playing music in my library with the sonos soundbar. I have tried "alexa, stop playing music in Library", along with other general "stop music" commands, but it does not work. Anybody have any other recommendations? Thanks.
you have to know that Sonos one is connected at severals providers, like amazon, Sonos, Spotify etc, so you have to check every provider and make combinations settings up amazon, Sonos principal, in this case i try whit ... go to Alexa app and choose " Living room ... not others but i think is different ad situations.
Userlevel 2
Badge +3
Just started having problems with my Play1 with built in Alexa to execute commands to play or pause music and change stations that have previously worked with no problems. Alexa responds with a chime and says ok but then nothing, then I must use the app to issue the commands. Whereas, upon issuing the same command to my Echo Dot, the command is executed immediately on the Dot as well any Sonos equipment where I tell it to play.

Note: Commands to the Alexa on Play1 to turn on Philips Hue lighting and ask for information like what the current time is works just fines.
Userlevel 2
Badge +3
Another interesting thing I just noticed. No matter what song I play on my system (through the Sonos app or by Echo Dot command) when I ask Alexa on the Play 1 what song is playing it responds with Lonely Boy by the Black Keys and so does the Echo Dot.
I recently installed Alexa on 3 Sonos Play:1 units and 1 Echo dot unit. After several days of working well, Alexa now does not respond to any commands to stop. This is true for music and radio, and I've tried several different versions of "stop": "shut off", "stop playing...", "shut up", and so on. I have also tried being explicit about what device to turn off. It happens when only one device is playing and when several devices are playing. I have not switched profiles. I have checked the Alexa history, and she is hearing commands correctly. The only thing that works is manually triggering the power button on the top of the Sonos unit.

This sure is frustrating. Is Sonos working on this?
Userlevel 7
Badge +19
Hello everyone. Here is an article that goes over the commands that work best using the Sonos Skill on Alexa.

If you are still having troubles using voice commands, feel free to give our support technicians a call to troubleshoot this in real time over the phone.
Userlevel 2
I have had the same problem when playing radio stations from Tune in. Sometimes it responds to "stop" and other times it doesn't. The Sonos One does not seem to work as well as the Amazon Echo's especially when trying to say "stop". It even rubs salt into the wounds by turning up the volume each time I say "stop". I find that the only way to stop it (apart from manual intervention) is to change from the radio to something like Spotify and then use the stop command. This works 95% of the time. In my view it is a glitch that needs to be worked out with the Sonos team but its a tough nut to crack because of the intermittent nature of the problem.

Reply