Alexa will not stop playing or pause

  • 3 August 2019
  • 94 replies

Userlevel 1
I have a Sonos Beam in my living room in a group with two Gen 1 Sonos One speakers and a Sonos Sub. I have had Alexa enabled since I initially setup this system.

All had been working well but suddenly, Alexa will not stop or pause playing by voice command. I can say "Alexa, play NPR" and it will respond properly. I can say "Alex Louder" and "Alex Lower" and the volume will adjust. But when I say "Alexa Stop" (which is what I've been saying since day one) or "Alexa Pause" it will simply make the command chime and keep playing.

Also, the Beam is working properly but in the Sonos app, I don't specifically see the Beam listed as a speaker. I think it might simply be labeled "Living Room?" I'm not sure if I should see the Beam specifically?

I tried to remove Alexa and reactivate it but I got completely confused and I'm not sure what I accomplished.

I'm now back to square one, with the same symptoms as described above.

I have an Echo Dot in another room that responds normally to Stop and Pause commands.

Best answer by UKMedia 4 August 2019, 10:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

94 replies

I’m having the same issue on 2 of 3 of my Sonos speakers, Alexa won’t pause or stop my music. Any news on a fix for this?

Yes, I'm still having the same problem. Any updates Sonos?

Userlevel 1

I started this thread 7 months ago.  There has been no fix.  I have gotten in the habit of saying “Play WNYC” instead of “Play NPR.”


I’m not a Sonos engineer but saying “Play NPR” seemingly uses some kind of “skill” that is flawed and will not allow the user to stop or pause play.


Saying “Play WNYC” apparently uses TuneIn to stream the station, and pause and stop work as they should.

Userlevel 2

I too have this same issue. Started recently after working fine for months. Alexa pause, shut up, and stop commands no longer work for BBC Sounds or Amazon Music

*!!!Thanks Firewater,*** your process help me solve the issue with took me the whole day to figure out.

“ step 1: in the Sonos amp remove amazon music.

step 2: disable Sonos skill in the Alexa app and remove all sonos speakears froms your groups

step 3: either using the amazon app or the webpage go to device and contents section and deregister each Sonos device found those three steps takes about 1 min.

step 4: factory reset all devices all but one. (This will make added devices back quicker)

step 5: in Sonos app go to settings>system>add device add all speakers. Then Factory reset the last speaker and add it back (for me this took about 4 mins for three devices)

step 6: add amazon music back in Sonos app

Step 7: add Sonos skill back in the Alexa app

step 8: run discover if the Alexa app didn’t do it. You can do so by voice command or via Alexa app.

You should be able to test the system now. This error is possibly an issues between Sonos systems and amazon servers. The factory reset forces a new connection between Sonos and amazon servers. I’m not sure if a software update can do it alone. This could be sonos’s fault but could also be Amazon’s fault. “

Factory resetting of Sonos devices is NEVER needed except in very special circumstances, and it erases important diagnostic information.  A reboot will suffice. 


Factory Reset: What you need to know



Userlevel 2

This started working on most of my Sonos speakers after upgrading to the new Sonos 2 app.  Some still refuse to accept the commands, however

Userlevel 2

Now “pause” and similar commands has stopped working in all my Sonos speakers yet again.  None of the steps in this thread help unfortunately.  So frustrating.  Anyone had any success with other solutions?

Userlevel 1
Badge +2

Alexa won’t ‘Stop’ my Sonos music either (two different Beams) but saying ‘Alexa Cancel’ seems to pause it.  Why Sonos can’t get this figure out after TWO YEARS should embarrass someone…. 

Alexa “STOP” is a crucial command for all Alexa enabled Sonos products and the “STOP” command is working fine in all my (8) rooms with a separate Amazon Echo device. However, the “STOP” command does not work on my (3) kids Sonos One Gen2, but voice commands like “PLAY” & “MUTE” ++ works fine.

Correct me if I’m wrong, but I believe that the reason for not fixing the faulty product or giving this community a real explaination about the problem, is due to the poor cooperation between Sonos and Amazon - not the best partnership maybe? 

I planned to upgarde all my devices to Gen2, but without a real and honest feedback from Sonos and a promise for a permanent fix for the above bug, flaw, fault (including fix date), I will not. I’ve heard the same from other Sonos users as well…



I have the same problem on my two sonos ones, they will not stop, cancel or turn off to voice commands. They will change station, adjust volume and perform other voice commands but won't stop. I have tried all the suggestions on thread.

I’ve been onto Sonos several times and no solution. The last attempt was to turn off internet router and devices which seemed to work, for a day. They ended the conversation saying my internet was the problem. I’m not saying it isn't but this only started a few months ago and worked well for the 2 ish years before. I also have an amazon speaker which works.


I would love a sonos fix.



Go to support page, choose fix an issue, Voice assistant issues, Alexa commands not working on Sonos. It involved disable sonos skill, deregister sonos speaker from 

amazon, remove voice command and sign out of Alexa app and re-set up of the speaker. I just tried it today and it works.

Hi Sam-bam,

Thanks for the info above. I tried and no success.

What I did find this morning is it won't stop whilst playing a radio station from Tunein but it will if I switch to spotify and stop from there. Strange.

I will chat with Sonos later today and see what they say.

Userlevel 1

Problem still exist. If I reboot my play 1, it will start working for a few days and then it acts up again and won't stop Amazon music. It's extremely frustrating as we use the Sonos to listen to music while getting ready and are use Alexa to stop the music quickly (as we're mostly in a rush). 

The fact is that there is a problem and multiple people are experiencing it (whether Sonos chooses to address it or not). I should not have to jump through a flaming hoop every week to get my device working properly. The Play 1 that I referenced is not within easy reach and unplugging/replugging requires moving the bed.

Hi JRM523,


My problem has gone away. I had a local radio station app installed on alexa and once removed my sonos devices work as expected. I now play the local radio station via tune in.


I will say for the most part Sonos support were useless, one guy had me plugging and unplugging devices and then decided my internet connection was not good enough. The last person I spoke with had a better idea and I took from the conversation that some 3rd party apps cause problems and its essential to complete all updates.

I have a Sonos beam grouped with two One SLs grouped as surround sound for the television. Alexa was fine until i invested in two Sonos Ones for the kitchen and breakfast room - which are grouped. Alexa then refused to respond to the stop command on what seemed a random basis across the devices. The pause command however, did work. Attempting to address the problem via the suggested solutions (complex and tedious)  has simply made matters worse. The main issue now is that whilst i can invoke services on the tv group it is impossible to terminate them with any command and Alexa claims not to understand what pause means! have spent hours on this and finally admitted defeat. Sonos tout Alex as a major feature for their products. It does not work. Fix it please.


I'm having the same issue on 1/3 of my Ones.

It will tell me the weather, time, etc, but won't pause or play music.

Just asked it to pause, it didn't.

Diagnostic 644808293

Userlevel 7

@lylesback2 Have you tried disabling the Sonos skill and enabling it again in the Alexa app?

@lylesback2 Have you tried disabling the Sonos skill and enabling it again in the Alexa app?

That actually did work, thank you!