Answered

Alexa Spotify: This device is offline

  • 6 January 2024
  • 10 replies
  • 1706 views

Userlevel 3
Badge +3

When asking Alexa to play Spotify through Sonos Arc it would say: "This device is offline".

When asking through an Alexa Echo device it would say: "Sonos is offline".

Playing Spotify worked fine when not using Alexa.

icon

Best answer by Stéphane Lenclud 6 January 2024, 12:48

View original

10 replies

Same here, I came back from a short trip and found Alexa responding “this device is offline”, I then tried everything listed here, also a factory reset and setting up everything again, but cannot get Alexa set up anymore. On the Amazon app, it can't find the Era 100 device; on the Sonos app, when I get to the "Signing in to Amazon...” dialog, it hangs there forever. Infuriating...

Userlevel 3
Badge +3

To fix it I had to remove the Sonos Alexa skill and add it back again. It kept all my devices room setup it seems.

Open the Alexa app tap on More, tap on Skills & Games, scroll to the bottom and tap on Your Skills, tap on Sonos, tap on disable skill.

Then just add it back. You will need to link your Sonos account again.

 

Spent an hour on customer service chat, tried various versions of resetting stuff, nothing worked… was finally asked to call in to tech support, but getting in touch with them is horribly difficult, I'm on hold now, "wait time is 70 minutes” :-) I think I've had enough of Sonos and it's time to purchase new speakers...

Same here, my Sonos Arc in the Alexa apps says “Device offline”

Tried removing the skill and adding again to no avail.

 

Spotify works fine on the ARC, TV Works and connection from the Sonos App.

 

It worked previously so what do we all try now?

I'm having the same issue. I tried disabling and enabling the skill to no avail. It's been working well for many years, until this week.

To fix it I had to remove the Sonos Alexa skill and add it back again. It kept all my devices room setup it seems.

Open the Alexa app tap on More, tap on Skills & Games, scroll to the bottom and tap on Your Skills, tap on Sonos, tap on disable skill.

Then just add it back. You will need to link your Sonos account again.

 

Looks like this Basic advice simply does not work for most of us.

I’ve tried the above and disabled the Sonos skill on Alexa but it won’t then allow me to re-link my accounts and enable the skill again. Alexa keeps saying I need to register all of my Sonos products to the email address that’s linked to my Alexa account. They are and whilst Sonos/Spotify are working fine, Alexa just keeps saying “this device is offline” and not allowing me to enable the Sonos skill again. 

 

It’s driving me mad as Alexa/Sonos was working totally fine until I got rid of my old wifi network and installed a new one. Alex/Sonos/Spotify are all on the new Wifi too. 

 

HELP! 

Same issue and disabling the skill didn’t work. It’s driving me mad!

Hello, 

I have the same problem, affecting all my Sonos devices with Alexa, which all worked fine until very reverently. 
tried disabling and enabling the Spotify skill and linking the account again. No joy. Spotify only working via Sonos app. 

Alexa just says this device is offline. 

any further suggestions, please? 


 

I am having this same problem! I have tried all the suggestions above but it’s still not working. It just keeps saying it’s offline. It was working fine until I switched Wi-Fi. Please HELP! 

Reply