Answered

Alexa responds but will not play music

  • 25 November 2017
  • 28 replies
  • 179731 views


Show first post

28 replies

Badge

Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

Moderator Note: If the information listed here did not resolve your issue, try this topic: Resolving the Majority of Issues with Alexa on Sonos

Thank you so much for posting this; I had the same issue and after 2 hours of searching online and deleting/reinstalling apps/going through settings on Sonos/Amazon Music/Alexa, I was beginning to go crazy. This fixed it for me! I still don’t know the root cause however as it’s been working fine for 1-2 years. All I can think of is that I changed my Amazon password recently.

Disabling and re-enabling worked for me too. Well, it sort of worked. If I ask Alexa to play music, it will default to the Echo Dot despite it being paired with the Play:5. If I specify where to play the music (in the living room), Alexa will send the output to the Play:5.

I thought/remember that by grouping the Dot and Play:5 through the Alexa app and setting the preferred speaker to the Play:5, Alexa default to the Play:5. This no longer works for me. Has this functionality changed?

Disabling and enabling Sonos skill via the Alexa app did the job - spot on thanks!!

Reply