Answered

Alexa Requests No Longer Play on Sonos

  • 23 April 2022
  • 8 replies
  • 154 views

Userlevel 1
Badge +1

Yesterday while playing a station on Sonos Five which was initiated via a request through my Amazon Echo, the station would not stop. I had to touch the Pause button on the Five. Today, I found that any request to play Sonos via Alexa Echo or Alexa App will not play anything. In troubleshooting I removed the skill, added it back in, removed the group and added it back in, removed the devices and re-discovered, rebooted everything. All firmware is up to date. Up until yesterday all had been good.

Right now on the Alexa app I have the Sonos skill enabled and the Sonos Five enabled. I have no Alexa groups. I can play on the Sonos Five via the Sonos app. I can play on the Echo via a Alexa voice request to the Echo or via the Alexa App.  I can request Alexa to play to my Sonos Five via voice request to the Echo. It is acknowledged but no sound comes out. I can request The Sonos Five to Play via the Alexa App, but it does not start playing and does not show the playing bar on screen.

I am not sure what happened or what I can do to repair this. I know I made no changes that stopped it from working. I sure would appreciate any advice from the Sonos community on what I might do to fix this, and get it back to working like it was before.

Thanks!

icon

Best answer by Ontario1 23 April 2022, 17:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +20

As a test.  When you ask to play music to your Sonos Five, can you repeat the same command a second time.  There have been some issues whereby, it is necessary to repeat the command for it to work with the first voice command.

Userlevel 1
Badge +1

Hello UKMedia. As a test, I tried to repeat the request (tried 3 times). Alexa acknowledges the request. But it has no sound. I know the Sonos Five is working, as pressing the play/pause button continues playing the last thing that was requested via the Sonos App.

Thanks.

Userlevel 1
Badge +1

Well, after removing all my Sonos Apps and Alexa Apps on all my devices, I logged into Sonos.com to remove the registration of my devices, thinking I would start all over again.

When I logged into the Sonos.com, there was a pop-up notice on the screen to the effect:

Alexa Voice Control Functionality Issues

Investigating - We've identified a problem with Alexa Voice Control on Sonos and are working with them on a fix. You may not be able to add your account until it's resolved. 

 

So, I think that is in fact the issue.

For others having this problem, suggest sit tight for a bit and hopefully Sonos and Amazon will resolve this quickly for us without us having to do too much more. (But for me, there is a lot, since I have to start all over again.)

 

Regards,

Userlevel 1
Badge

Thanks for posting this update.  I’m not a regular, but checked the forum to see if anyone else is experiencing Alexa problems because it’s not working today (Alexa acknowledges the command, but nothing plays). Glad to know it’s a known issue and they’re working it. 

Badge

Thanks for posting this -- I’ve been troubleshooting (hopelessly) an ongoing problem with my S1 system I described in another thread requiring asking Alexa twice every time to play music from Spotify, and discovered tonight it’s not working at all!  I’m actually somewhat relieved to hear this outage is a Sonos-wide problem.

While you’re at it, Sonos, PLEASE also fix the problem that requires asking Alexa twice to play Spotify music on S1 systems via Alexa!!

Thank you for your post!  I hope Sonos can fix this ASAP.  Please let us know if you receive an update.

Thank you.

Sonos, Please fix this!

I just sent an email to the CEO, Patrick Spence.  If everyone joins me we may be able to expedite resolution.  ceo@sonos.com

 

Userlevel 4
Badge +5

I’m not convinced that cryptic notice that Sonos posted is actually the solution. It says you may not be able to add your account. The problem we’re having has nothing to do with adding accountes, it’s that you can’t play any music (which is kinda the whole point of having speakers unless I’m missing something). Can someone from Sonos please comment if this is indeed a known issue and if so, if they plan to resolve it? Emailing the ceo is creative but if someone with official knowledge could post something helpful here, that would be really great. I wasted a good part of my weekend trying to troubleshoot this.