Answered

Alexa refuses to play from configured speakers- my group keeps getting separated

  • 23 March 2022
  • 8 replies
  • 88 views

Userlevel 1
Badge +1

I have a large kitchen/diner. I have 2x stereo pairs of Ones- called Kitchen 1 & Kitchen 2 in Sonos.

Clearly I now have 4 Alexa’s in the same room but, due to the pairing, the 4 appear as just two Alexa devices in the Alexa app until you click on each ‘Alexa device’ and it has two speakers inside it, both of which can be configured.

What I want: a permanent grouping of Kitchen 1 and Kitchen 2 so that whatever I do, they play together, ie. all 4 speakers play (as 2 stereo pairs) all the time under the command of the Sonos app and Alexa.

What I get: an infuriating mix of, group them in Sonos, everything works fine… until at a random time when someone says “Alexa play...” it decides to break up the group and play from only one pair until I regroup them in the Sonos app. This is driving my nuts.

I have tried what I think is *everything*… but I live in hope that the magic combo is out there somewhere.

I have created a room called “Kitchen” in Alexa grouping the two Sonos pairs, Kitchen 1 and Kitchen 2. There are no other devices in the Alexa group.

The confusing thing is that I can configure the preferred speaker in two places. Firstly, each of the 4 Alexa devices can use (1) built-in speaker, (2) the room ‘preferred speaker’ or (3) “let Alexa decide”. Secondly, I can go into the group and select which speakers to play from and whether to require the room name or always choose those speakers.

I figured that I simply go into the group called Kitchen, select both Kitchen 1 & Kitchen 2, then ‘always’ and it would always play on both pairs of speakers every time. Sadly it completely ignores this configuration and follows whatever is the current grouping in the Sonos app. ie. if the two pairs are grouped in Sonos then all 4 will play, if not grouped then only one pair will play.

This is driving me totally nuts!

IF ONLY SONOS WOULD ALLOW PERMENANT GROUPING OF MULTIPLE SPEAKERS IN THE SAME ROOM

I have played with so many combinations of settings of each Alexa and the group but I just can’t make it happen.

Any ideas anyone?

icon

Best answer by Ken_Griffiths 25 March 2022, 11:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Here is my suggestion…

  1. Place the two Sonos ‘speakers’/‘rooms’ you currently have available into the ‘enabling/controlling’ (first) section of the Alexa group.
  2. Also add the same rooms to the (third) ‘speakers’ section of the group.
  3. Set the group ‘Playback Option’ to ‘Always’… and … If there no other speakers, remove all other Alexa groups, so there is just the one group only.

Then on requesting music playback to any Sonos Alexa component on those speakers - the two Sonos stereo pairs will auto-group together (if separate), or will remain grouped (if grouped already) and play the requested audio to both stereo pairs.

If you have other echo/Alexa devices in the same room also add those to the ‘enabling/controlling’ (first) section of the same Alexa group.

I have a large kitchen/diner. I have 2x stereo pairs of Ones- called Kitchen 1 & Kitchen 2 in Sonos.

Clearly I now have 4 Alexa’s in the same room but, due to the pairing, the 4 appear as just two Alexa devices in the Alexa app until you click on each ‘Alexa device’ and it has two speakers inside it, both of which can be configured.

What I want: a permanent grouping of Kitchen 1 and Kitchen 2 so that whatever I do, they play together, ie. all 4 speakers play (as 2 stereo pairs) all the time under the command of the Sonos app and Alexa.

What I get: an infuriating mix of, group them in Sonos, everything works fine… until at a random time when someone says “Alexa play...” it decides to break up the group and play from only one pair until I regroup them in the Sonos app. This is driving my nuts.

I have tried what I think is *everything*… but I live in hope that the magic combo is out there somewhere.

I have created a room called “Kitchen” in Alexa grouping the two Sonos pairs, Kitchen 1 and Kitchen 2. There are no other devices in the Alexa group.

The confusing thing is that I can configure the preferred speaker in two places. Firstly, each of the 4 Alexa devices can use (1) built-in speaker, (2) the room ‘preferred speaker’ or (3) “let Alexa decide”. Secondly, I can go into the group and select which speakers to play from and whether to require the room name or always choose those speakers.

 

 

Hard to tell if you have this setup right.  Your correct that you need to setup an Alexa group.  In the top section for Alexa devices, you need to have all the devices with Alexa voice in the group. That should just be kitchen 1 and 2 for each stereo pair you have setup.  Then, in the Speakers section, you should have the same two stereo pairs setup.

With this setup, it means that whenever you request to play music via Alexa voice, it should play on both speakers.  Commands to change volume should also be on both, I believe.  Stop should stop anything playing.

 

I figured that I simply go into the group called Kitchen, select both Kitchen 1 & Kitchen 2, then ‘always’ and it would always play on both pairs of speakers every time. Sadly it completely ignores this configuration and follows whatever is the current grouping in the Sonos app. ie. if the two pairs are grouped in Sonos then all 4 will play, if not grouped then only one pair will play.

 

 

Giving what voice commands?  Some commands, like ‘resume music’ is going to play on whatever had been paused, regardless of group.

 

You can save a group in the Sonos app, but this is not really related to Alexa groups.  Just a short cut for common groupings.  If you always play these two rooms as a group though, never grouped with anything else, I’m not sure why they are ungrouping.

 



This is driving me totally nuts!

IF ONLY SONOS WOULD ALLOW PERMENANT GROUPING OF MULTIPLE SPEAKERS IN THE SAME ROOM

I have played with so many combinations of settings of each Alexa and the group but I just can’t make it happen.

Any ideas anyone?

 

I agree that allowing to ‘permanently’ group 2 or more rooms together would be a nice feature.  The only reason I see not to do this is that it cause confusion with things like trueplay tuning, volume control, and existing integrations with other systems. maybe one day.

Userlevel 1
Badge +1

Thanks for trying folks, but I believe this is exactly how I have it set up already. The damn thing simply refuses to group and play all together if the group is not already done in the Sonos app. So, if I group manually in the Sonos app everything works fine until something decides to forget the grouping again.

How the group is getting broken up doesn’t make sense to me at all. 

 

 

 

 

Userlevel 1
Badge +1

I am going to try again with this same setup, but with the configuration of ‘built in speaker’ set to each of the 4 Alexa devices (previously were set to ‘let Alexa decide’… which has now become not selectable)….

“Cover me, I’m going in”...

 

 

 

 

Yes that looks fine, but … what other groups are there? Are the Sonos devices listed in any other Alexa group?

Presumably the speakers are not powered off, but perhaps try increasing their IP address leasing time, or reserve their IP addresses outside of the general pool of assigned IP addresses on your router and see if that stops the group regularly separating.

I am going to try again with this same setup, but with the configuration of ‘built in speaker’ set to each of the 4 Alexa devices (previously were set to ‘let Alexa decide’… which has now become not selectable)….

“Cover me, I’m going in”...

Ha ha 😂 - I just checked and my Alexa settings each say ‘built in speaker’ FWIW

Userlevel 1
Badge +1

Yes that looks fine, but … what other groups are there? Are the Sonos devices listed in any other Alexa group?

Presumably the speakers are not powered off, but perhaps try increasing their IP address leasing time, or reserve their IP addresses outside of the general pool of assigned IP addresses on your router and see if that stops the group regularly separating.

now…. there’s an idea. maybe I will go into my Unifi controller and reserve an IP address for all (18) of my Sonos devices. 

I am also thinking of stripping all 4 kitchen speakers (and their accompanying sub) out of everything (remove from Sonos etc.) and adding them again. I have a feeling that sometimes something weird happens when you add a voice compatible Sonos device. Initially it is simply a ‘speaker’ accessed via Sonos API. Then, when you enable voice control it becomes an ‘Alexa device’ and I am not completely convinced that this transition is 100% rock solid.

I have trawled through all my (many) Alexa groups to check that these speakers are not listed in any other group.

With a UniFi system in place, have you set the following settings:

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Also enable IGMP Snooping (which is in the Networks settings page).