Alexa periodically stops working on Move

  • 12 December 2020
  • 9 replies
  • 113 views

Badge

I purchased the Move about a month ago. Have it linked to Alexa and use it mainly to play on Spotify. Voice commands will work for a period of time then will stop responding to Alexa. Only thing that works is removing Alexa via the Sonos app then re-adding. That will work for a period of time then it will stop working again. I’ve tried resetting the Move, enabling/disabling the skill in Alexa, logging out of Alexa and logging back and nothing works. The only thing that gets the voice commands working again is deleting & adding the voice assistant in the Sonos app, which again only works for a period of time before it stops responding to the Alexa voice command. 
 

Any thoughts?

Thanks a lot

Sonos diagnostic code: 169626

 

 


9 replies

Userlevel 6
Badge +17

Hi @Ryan888.

Welcome to the Sonos community and thanks for bringing this to our attention. I understand your situation especially if we have tried some possible tips and tricks but only works for a while and then goes back to not working again. Let me share some troubleshooting steps that might help you out.

Allow me to recommend the following guides and please do follow accordingly. This is a permanent fix to a possible glitch between Sonos and all Amazon related apps which includes the Alexa app.

  1. Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  2. Open the Amazon Alexa app and disable the Sonos Skill.
  3. De-register any Sonos product on the Alexa App.
  4. Open the Sonos App.
  5. Remove the Alexa Voice service.
  6. Force close Sonos app.
  7. Force close the Alexa App.
  8. Reopen the Sonos App. Add Alexa as a voice service.
  9. Open Alexa app Add Sonos as skill
  10. Register Sonos speaker
  11. Add music service.
  12. Test to check if it works.
  13. Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes and keep me posted.

Thanks,

Badge

Thanks for those steps. I have tried all on several occasions. The only one that works is removing the Alexa voice service via the Sonos app and reinstalling. That will fix it for a period of time before it randomly stops working again. I’ve included my diagnostic  code in my initial post and included it again below for convenience. Is it possible I have a defective unit? Thanks again.

 

Sonos diagnostic code: 169626

 

 

Userlevel 7
Badge +20

Thanks for those steps. I have tried all on several occasions. The only one that works is removing the Alexa voice service via the Sonos app and reinstalling. That will fix it for a period of time before it randomly stops working again. I’ve included my diagnostic  code in my initial post and included it again below for convenience. Is it possible I have a defective unit? Thanks again.

 

Sonos diagnostic code: 169626

 

 

Can you check a really silly thing and I apologise if this is way off the mark but is there a chance that when dusting someone is accidentally turning the mic off?  It’s very easy to do, speaking from experience! :(  When this happens again, please touch the mic symbol on the top of the Move and ensure the small round white light remains illuminated. 

Badge

Thanks UKM. Sometimes it is that simple, like the power is off, but the mic light is lit. I’m using it a lot today and waiting for it to happen again. I did a reset two weeks ago (wiped it clean with all my data) with the hope I fixed it but it did it again last night and had to again delete and reinstall the voice services. Frustrating. I’m wondering if Spotify is doing something to the device or app. I’ve literally tried everything, turning the device off/on, resetting everything but only solution is removing Alexa via the Sonos app then like magic it works again for a period of time. So odd. 

Userlevel 7
Badge +20

Removing and then re-adding Alexa would also turn on the Mic! :) 

Badge

You’re right, it would. I recall seeing the lights lit on the top but you never know. I’ll pay closer attention next time it happens. Will circle back next time it occurs. Appreciate everyone’s responses. 

Badge

So it’s been a while since it’s happened and I do believe it’s because I was probably accidentally turning off the mic. Thank you UKMedia. I feel pretty stupid about it but also glad I found out why it was occurring. 
 

Happy holidays. 

Userlevel 7
Badge +20

So it’s been a while since it’s happened and I do believe it’s because I was probably accidentally turning off the mic. Thank you UKMedia. I feel pretty stupid about it but also glad I found out why it was occurring. 
 

Happy holidays. 

Don’t worry you’re not the first and you won’t be the last. :)  Stay safe and Merry Christmas :)

Badge

Same to you! Stay safe/well. 

Reply