Answered

Alexa only plays the queue on Sonos

  • 5 October 2017
  • 28 replies
  • 1410 views

Hi, I set up my bedroom Play1 tonight with an Echo Dot and followed all the directions. Currently, if I ask Alexa to play something specific, Sonos just kicks on and plays the current queue. If I clear the queue and try again, Alexa tells me that the Bedroom is not responding. I have also set up Amazon Music as the default service in Alexa and added it to my Sonos account. Am I missing something?
icon

Best answer by Mesberg 6 October 2017, 01:50

Solved it. You can't have an Echo with the same name as the Sonos device you are trying to control. In my case both were called Kitchen. I renamed the Echo Dot to 'Echo Kitchen' and now its working perfectly.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

Userlevel 7
Badge +20
Try disabling Voice Control within the Android or iOS Sonos app Settings>Sonos 1 and then re-enable.
Cannot find that setting...
Userlevel 7
Badge +20
Cannot find that setting...

In the Sonos app (Function is only available on Android or iOS not the PC version) open Settings>Room Settings and select your Sonos 1. At the top of the screen is a section labelled 'Voice Services', sign in to your Alexa account and you can select 'Remove'.