Alexa only plays the queue on Sonos

  • 5 October 2017
  • 28 replies

Hi, I set up my bedroom Play1 tonight with an Echo Dot and followed all the directions. Currently, if I ask Alexa to play something specific, Sonos just kicks on and plays the current queue. If I clear the queue and try again, Alexa tells me that the Bedroom is not responding. I have also set up Amazon Music as the default service in Alexa and added it to my Sonos account. Am I missing something?

Best answer by Mesberg 6 October 2017, 01:50

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

hello Carl I have the exact same problem, I ask alexa to play music and is says bedroom not responding, and only played the qued music, I cleared the music and it plays nothing now
Userlevel 5
Badge +3
stemac - Are you using spotify as your default music service? If so then this would be expected behaviour as it doesn't work with spotify.

CarlD74 - can you try using echo/alexa without the sonos and just check that it plays amazon music through the echo/dot. It may be that the problem is not with the sonos/alexa connection, but the link to amazon prime music itself.
Cchris no am using amazon and google play for streaming 🙂
I have exactly same problem and am using amz unlimited
Same here (with any/all rooms)
I have the exact same issue.

I have 2 original echo's and 3 dots.
I have 2 Play 1's and 2 Play 5's.

I have even removed the skill as well as the devices added to echo, then added the skill back. I get the same result.

I also unplugged/plugged the power in the echo's and Speakers.

That worked! Try it and let me know if it worked?
Userlevel 2
Badge +1
In all of these cases, are your Sonos speakers showing up in the Alexa app?
Yes, the were.
Fubie3, what order did you unplug/plug the devices. I want to try replicating your solution, but the order may matter.
I just did 1 echo, then 1 sonos, both in the same room.
Thanks. I'll try that tonight and see if it works for me as well. Just to be extra clear. You power cycled the Echo first, and then power cycled the Sonos. Right?
Userlevel 5
Badge +13
Getting the same issue here with my queue source being Apple Music and having access to Amazon Prime music (not prime)

Tried in 2 of my 3 rooms with Sonos and echo dots.
Thanks. I'll try that tonight and see if it works for me as well. Just to be extra clear. You power cycled the Echo first, and then power cycled the Sonos. Right?

Yes, I did an echo 1st, then a Sonos Speaker Play 5 that reside in the same room.

After that the rest of my speakers work with any echo.
Userlevel 5
Badge +13
Just tried again in the 3rd room and Alexa just says “OK” then nothing happens
Try just turning the volume down.
I tried the power cycling but it didn't help me. Literally the only thing that I can get to work is to get music that is already in the queue to start playing. Doesn't matter whether I ask for a specific artist/song/playlist, it just plays the music already in the queue. Instructions to pause, skip, etc. have no effect. Anyone have any fresh ideas?
Solved it. You can't have an Echo with the same name as the Sonos device you are trying to control. In my case both were called Kitchen. I renamed the Echo Dot to 'Echo Kitchen' and now its working perfectly.
Mesberg thank you very much for that 🙂 mine is now working 🙂 still having little problems tho like volume control ?
Userlevel 5
Badge +13
@mesberg - thanks .... yes that seems to have fixed it.... i renamed the Echo Dots to have different names from the Sonos devices and it now seems to be working better
@mesberg - awesome discovery! That was exactly my issue and now works well since I changed some names. Thank you!
I have exact same issue with ‘kitchen’ too - i’ll Try your suggestion
I have this same issue ... if nothing is playing I get a message “Sonos is not responding” but if I had music in my queue it just starts that back up. I have tried every suggestion in this thread now twice basically. Sigh.
Same issue here. I have cycled the power but no change. It will play the queue but says not responding if there is noting already queued!
Assistance please...?
Userlevel 7
Badge +20
Have tried Disabling then Enabling the Sonos skill within the Alexa app?
Yes, already tried that...