Answered

Alexa on Sonos One / Beam not working properly


Hello there - I need help regarding my Sonos One and Sonos beam speakers with Alexa. When I ask Alexa a regular odd ball questions she responds just fine something like “how far is the moon” or “who won the game last night” - but when I tell her to go through my flash briefing she says “here’s your flash briefing” than crickets/nothing happens..... or something like “play John Mayer in Apple Music” and she responds “to do that, the skill needs to be activated in the Alexa app.” Or something of that nature. The thing is - all of these things are enabled and music/media accounts are all linked up. It was working properly before but now it doesn’t seem to work ever.

I even when as far as resetting all 4 of my speakers (One; 5, Beam, and play 1) and restoring factory defaults and re set up all of my speakers. I am definitely at a loss. Any help or feedback is definitely appreciated - sucks I paid this much money for speakers that the wireless “voice” functionality doesn’t work. Thanks all!

-Andrew
icon

Best answer by agacom 2 May 2019, 13:27

Hey guys! So I found a fix myself!

So I first changed my email on my amazon account to match my Sonos email. Not sure if that did anything or not but i figured it wouldn’t hurt. After that I unlinked my music in the Alexa app and re-linked them - once that was complete I went to my devices in the Alexa app and removed my devices completely. After that I clicked the plus sign in the top right hand corner of the app and clicked search for devices. It found 5 devices - for some reason it listed my Sonos Beam twice - one said “Sonos Beam” the other one said “Sonos Beam TV.” After these were all added I did the following step below.

After I did that I went into work the Sonos app>room settings>Chose the specific speakers (I had two with Alexa) and removed the alexa function for each one. Then went back and authorized the Alexa speaker again for each speaker.

After that - a miracle happened and everything works. My flash briefings somehow work now, my music functionality through Alexa using Apple music and Spotify now work. And somehow - my Sonos Beam can finally turn my tv on and off! I never thought that functionality would work but I have it a whirl and it worked!! I hope this may solve some issues with other people on these forums - seems like a ton of people are having this same/similar issue.
View original

13 replies

Userlevel 7
Badge +20
Can you first disable the Sonos skill and then re-enable.
I already disabled then enabled skills. Still nothing,
I already disabled then enabled skills. Still nothing,
There's a temporary outage affecting Alexa and Spotify Connect.

https://status.sonos.com/
How long as the outage been there? This legit has been happening since January so if it’s an outage i wouldn’t call that temporary.
I also use Apple Music more than Spotify. I’ve been asking Alexa to play music through Apple Music and keeps saying I need to enable skills (see first post). The comical thing is - I had a message in the Sonos app yesterday to tell me to try and use Apple Music with alexa and how to set it up. Followed the instructions perfectly and it still didn’t work and is asking me to enable the skills.
Userlevel 7
Badge +20
I'm not sure why this would change but can you check the location in www.sonos.com and your device set-up within the Alexa App. The other thing to check is duplicate devices names in the Alexa App.
Userlevel 7
Badge +19
I don't know how long this has been going on, but we do have an outage at the moment. I would suggest that we abstain from any further troubleshooting until that has been resolved, which hopefully will be before too long.
Hello!

So first I’ll respond to UKMEDIA:

- so I logged into Sonos.com and I see my products own. I don’t see anywhere that gives a location for my products. I do see a location listed in Alexa app and those address for both speakers are correct. Also I checked the Alexa app and there are no duplicates.

@EdwardR

I think we can continue on since this issue was long before the outage. Per my original post I’m having more issues than just the music. Skills like “play my flash briefing” does not work. Alexa says “here’s your flash briefing” then nothing happens.
Userlevel 7
Badge +19
Hi there, Andrew. Absolutely, I did notice it's been going on a while - the only reason I mentioned the outage was because even if we managed to fix it, we wouldn't know if the outage was still ongoing, if that makes sense.

Thankfully that's all over and done with now, so we can go about fixing this for you! I did write up a post elsewhere that contains some recommended troubleshooting steps. I think that would be the next thing to try, if you've not already. If that proves unsuccessful, please respond back with a diagnostic confirmation number and we can see what's going on. Thanks!
Hey guys! So I found a fix myself!

So I first changed my email on my amazon account to match my Sonos email. Not sure if that did anything or not but i figured it wouldn’t hurt. After that I unlinked my music in the Alexa app and re-linked them - once that was complete I went to my devices in the Alexa app and removed my devices completely. After that I clicked the plus sign in the top right hand corner of the app and clicked search for devices. It found 5 devices - for some reason it listed my Sonos Beam twice - one said “Sonos Beam” the other one said “Sonos Beam TV.” After these were all added I did the following step below.

After I did that I went into work the Sonos app>room settings>Chose the specific speakers (I had two with Alexa) and removed the alexa function for each one. Then went back and authorized the Alexa speaker again for each speaker.

After that - a miracle happened and everything works. My flash briefings somehow work now, my music functionality through Alexa using Apple music and Spotify now work. And somehow - my Sonos Beam can finally turn my tv on and off! I never thought that functionality would work but I have it a whirl and it worked!! I hope this may solve some issues with other people on these forums - seems like a ton of people are having this same/similar issue.
Userlevel 7
Badge +19
That's great news! Thanks for circling back and telling us how you fixed it. I'm sure this will help others. Let us know if you need anything else. All the best.
Thanks Ed! Not a problem - I hate it when people don’t post how they fixed the issue! Hopefully this will help others. Have a great weekend!
Userlevel 7
Badge +19
Hah! You know what? So do I, Andrew! Thank you, you have a great weekend yourself!

Reply