Alexa not responding on all devices

I have a Play 1 and a Beam and Alexa randomly stopped working on both today (have checked the mic is on).

I have tried disabling/re-enable the skill, but am getting stuck when trying to enable the skill. I get the “You need to link speakers to your Sonos account before you can add this skill.” error even though I can see my devices in the Sonos app fine. 

Going to the settings of each individual device shows the following under Voice:

“There was a problem retrieving Voice Services account information for this room. Please try again” - this was the case before trying to make any changes.

What I have done so far:

  • Disabled the Sonos skill in the Alexa app and deleted all Sonos devices from Alexa, logged out and back in to the Alexa app
  • Checked that my Sonos account has a valid postal address (this was suggested as a solution in another thread)
  • Attempted to disable Alexa from within the Sonos app, but it does not show up to allow me to do so - when I go to Settings > Services & Voice, I only see “Add a Voice Assistant” as if it is not linked, if I select Alexa to try and add it, it tells me “Amazon Alexa is already on all your Sonos products. To change or remove Alexa, go to the voice service settings in the Sonos app”, but I don’t see any option to do so.

Any suggestions much appreciated!


Best answer by Corry P 17 March 2022, 13:05

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +20

Can you follow the steps in my post here and let us know if the problem persists.

I think I am falling at the first hurdle - my Sonos app seems to be in a strange state where Alexa does not seem to show as enabled (I do not have a “Sonos App>Settings>Services and Voice>Amazon Alexa” item, only an option to add a voice service) but when I go to enable it it tells me that it already is?


Maybe try resetting the Sonos App from ‘Settings/App Preferences’ - then on reopening the App, choose the option to connect to the ‘existing’ Sonos System and also sign into your Sonos Account in the App Settings.

Go onto remove the Alexa Assistant from your Beam - wait a few minutes and then re-add the assistant back to the Beam and see if that fixes the issue.

Tried resetting the app as described (also tried a full uninstall/reinstall) but still see the same behaviour unfortunately.

Userlevel 7
Badge +20

Are you using an iOS device?  If so please remove the app and reinstall.

Yep, using iOS. Did that with no luck, even tried installing on another device.

As things stand I’m tempted to create a new account and move my devices across, unless that’s a bad idea/there are other less drastic things to try?

Userlevel 7
Badge +20

Can you try the other steps in my link above, ignoring the step that you are having issues with,

Yep, as follows:


Before we delve down to various resets, please open the Sonos App>Settings>Services and Voice>Amazon Alexa and ensure that your device is shown as Enabled – if not Enable.

Inconsistent app display, as shown in screenshots above.


1.1/ Please open up the Alexa App and press the ‘Devices’ button in the bottom right of your device.  You’ll need to make a note of any duplicate names, a common mistake is to have a Room and a Device with the same name. I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Bedroom Sonos, etc. Although this would appear to make the voice control of devices more complicated, the use of Groups, removes the need to name these specific Device names in most voice commands.  Here is a link to my naming standards:;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players.
1.3/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.

Not applicable as far as I can tell? All devices have been deleted from Alexa and the Sonos skill has been disabled, so no speakers are discovered.


Account Linking - Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps one at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';

Already disabled, unable to re-enable due to error in original post
2.2/ If you have multiple Amazon accounts logged into different Apps on your device, this can confuse the Amazon Authorisation. Please ensure that you log out of all Amazon related Apps and accounts and then complete step 2.1 again;

I only have a single Amazon account
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for at least 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

Done, same error

Userlevel 7
Badge +18

Hi @subtledee 

I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Can you please try the other steps in my link above, ignoring the one you're having trouble with?