Alexa no longer working with Sonos - again

  • 25 September 2021
  • 5 replies
  • 108 views

Userlevel 3
Badge +2
  • Trending Lyricist II
  • 28 replies

Alexa is acknowledging commands for my Sonos but they are having no effect (Sonos Play One)

Trying to re-link the skill doent help as there is an “oops” error message on the api page after logging in


5 replies

Userlevel 7
Badge +15

Same here.

Noticed it wasn't Ducking anymore so disabled the Skill but re-enabling gives the same ‘Oops.. ‘ error and doesn't add it.

I almost never use voice control as I find it far too inconsistent but I tried to ask Alexa something earlier and noticed it didn't Duck.

I was having to add some tracks back into the queue after I lost them all after a power glitch.

I still don't understand why Sonos can't/won't make the queue persistent after a power cycle - it's something that could even make me more inclined to switch to S2 if it was added.

Yup - same here in the UK. Requests for audio playback are still working on the built in Alexa in my One but requests to any other sonos like Play 1, Play 5, Playbar, Play 3 from any of my Amazon Echo just don’t do anything

Userlevel 3
Badge +2

The problem last month was probably with Alexa cloud as there was an error message from Alexa and it also affected Sonos with built in Alexa - but this new problem seems more likely to be at the Sonos API end.

Yep the same, however I also just did a hard reset and tried to re-install Alexa (didn’t work), then tried again with Google Assistant (also didn’t work). Hopefully they can patch it up quickly 

All seems to be back up and running this morning

Reply