Answered

Alexa mutes speakers

  • 7 October 2017
  • 43 replies
  • 6273 views

Userlevel 2
So, I'm upstairs in the shower listening to my morning podcast and it mutes itself every 10 seconds.

Come to find out my wife was in the kitchen using Alexa to make a shopping list.

How do I turn off this muting "feature" for Alexa? Or can I assign the dot to a single room so the whole house doesn't mute everytime someone wants a knock knock joke or the weather.
icon

Best answer by Ryan S 9 October 2017, 18:35

As MikeV said, the volume "ducking" will happen on all players across your system, grouped or not grouped. The only ones which shouldn't duck are those playing TV audio. That said, we're doing some more work on the ducking feature and will continue to improve the entire integration over time. You can expect to see the Alexa skill continue to adapt and move quickly. Thanks for the feedback guys!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

43 replies

Userlevel 3
Badge
I'm noticing the same thing, which is particularly annoying when using my Sonos 5.1 setup watching TV.
Userlevel 5
Badge +8
Why don't you ungroup the speaker from the kitchen one?
Userlevel 1
There seems to be no rhyme or reason to how this works right now for me. If I say “Alexa” in one specific room, that same room’s Sonos mutes (really just lowers volume). If I do the same thing in other rooms, whether Sonos speakers are grouped with the first one or not, the Sonos does not mute. Personally, I think the muting of the Sonos when directing commands to Alexa is a great feature (that I wasn’t really expecting) but there should be a way to link a Sonos room/speaker to and echo room/device so the mute function can be limited to the room listening to the command.
I have the same issue. Have the Echo Dot in the kitchen with two play 3's. When using Alexa to control the kitchen speakers, other zones in the house are dimmed. This is annoying, is there a setting I am missing to stop this happening? Other Sonos speakers are not grouped when this happens, so they are each playing their own thing. Thanks, Andrew
Userlevel 2
Why don't you ungroup the speaker from the kitchen one?

It is not grouped with the kitchen. I can have every speaker in the house playing something completely different and if I ask any Alexa something they all dim.

We using Alexa so much that this is making sonos almost unusable.
Userlevel 7
Badge +21
TV sources on Playbar and Playbase should not be affected by the volume "ducking" that Alexa does. However, any other Sonos speakers (or if the Playbar/Playbase are playing music instead of TV audio) will have their volume reduced.

There's not any option at this time to adjust how the volume reduction occurs. That's something that Amazon would likely need to implement, not Sonos.
Userlevel 7
Badge +26
As MikeV said, the volume "ducking" will happen on all players across your system, grouped or not grouped. The only ones which shouldn't duck are those playing TV audio. That said, we're doing some more work on the ducking feature and will continue to improve the entire integration over time. You can expect to see the Alexa skill continue to adapt and move quickly. Thanks for the feedback guys!
On my setup the volume on the TV does dim when I do Alexa commands in the kitchen. My TV is connected to a Sonos Connect Amp.
Userlevel 7
Badge +21
On my setup the volume on the TV does dim when I do Alexa commands in the kitchen. My TV is connected to a Sonos Connect Amp.

The Playbar/Playbase does NOT duck. ALL other Sonos components will as per MikeV's and Ryan S's confirmation.

We know that Sonos are aware that the ducking feature needs some work - For me (as I live on my own) ducking of other speakers not in the same room as I am is not an issue but I do find that it ducks for too long after I complete the command.
Userlevel 5
Badge +11
As MikeV said, the volume "ducking" will happen on all players across your system, grouped or not grouped. The only ones which shouldn't duck are those playing TV audio. That said, we're doing some more work on the ducking feature and will continue to improve the entire integration over time. You can expect to see the Alexa skill continue to adapt and move quickly. Thanks for the feedback guys!

Eek! That's my Sonos One order cancelled then. Did you guys not consider this scenario? Can't we have a setting on Dot's at least to turn off 'ducking'?
To me it's more of a Amazon issue that needs to be addressed so companies like Sonos can provide certain benefits. Until the API can use "spaces" to bundle things by room, localized ducking and other features cant be done. The Alexa would need to know which Sonos is nearby to duck even if it's playing music on a different room Sonos. Sonos did mention that the "...in the (sonos device name)" (saying the name of the room) is temporary and will improve. So maybe there is already something in the works from Amazon or Sonos.
Userlevel 2
It may be an Amazon issue that you can't associate an echo with a room, but sonos could provide a feature switch to turn this off for the entire system. Previous betas didn't do this.
Userlevel 7
Badge +22
Ducking can't be disabled currently. I think they at some point want to have Sonos units associated with closest Alexa unit so only that unit ducks. Personally I think they should have disabled the ducking until that can be done as I have same issue with Alexa's and Sonos all over the house.
Userlevel 5
Badge +11
What a ducking disappointment :D

... Sonos Skill - delete 😛
To me it's more of a Amazon issue that needs to be addressed so companies like Sonos can provide certain benefits. Until the API can use "spaces" to bundle things by room, localized ducking and other features cant be done. The Alexa would need to know which Sonos is nearby to duck even if it's playing music on a different room Sonos. Sonos did mention that the "...in the (sonos device name)" (saying the name of the room) is temporary and will improve. So maybe there is already something in the works from Amazon or Sonos.

I agree. It is impossible to provide the best possible user experience if the API you are working with is missing key features (Control4 can tell you just how frustrating that can be.) I think the good news in this case is that Amazon needs the ability to associate Echoes with other devices in a given room to improve things within their own ecosystem. Mainly for easier control of lights in the same room that you are speaking in. I think this will get pushed out pretty quickly on the Amazon side but even when available in the API there will have to be some work by Sonos to utilize it in the next firmware release. Maybe we could see room specific ducking and/or Alexa voice responses from an associated Sonos speaker by the end of the year?
Hmmm. I'm not getting any "ducking" on Sonos in any room, never mind all at once. Music is playing on Sonos, I say "Alexa..." and the music stays constant volume. Alexa on the dot responds normally. Any thoughts?
Userlevel 7
Badge +26
Hmmm. I'm not getting any "ducking" on Sonos in any room, never mind all at once. Music is playing on Sonos, I say "Alexa..." and the music stays constant volume. Alexa on the dot responds normally. Any thoughts?
What is the source of the music on Sonos when this happens, and how was it started? Do you have the same experience when it's started from Alexa vs from the Sonos app or another app entirely?
Hmmm. I'm not getting any "ducking" on Sonos in any room, never mind all at once. Music is playing on Sonos, I say "Alexa..." and the music stays constant volume. Alexa on the dot responds normally. Any thoughts?
What is the source of the music on Sonos when this happens, and how was it started? Do you have the same experience when it's started from Alexa vs from the Sonos app or another app entirely?


Good questions, all. I'll do some actual testing to see. But I know I have started music from Alexa and asked her something later and the music did not drop on my Sonos.

One aside, I think there may be some interference between multiple controllers. If I have Alexa driving to start, then launch the Sonos app on my phone and iPad, I have experienced "lock ups" on the Sonos system and no music plays. If I kill all the apps and tell Alexa to "stop" then I can get it going again from an app.
@Ryan S thanks for your response.

Frankly, it is difficult to understand how such a negative impact to UX made it through the betas we watched happen. At a minimum, would expect Sonos to list this as a limitation on the Alexa page. Please note that this feature has me considering disconnecting Sonos from Alexa; seriously, it is that disruptive --one Alexa interaction ducks all audio across my house.

Do you have an ETA on a resolution or workaround?
I cannot understand why Alexa Dot works perfectly when plugged into a stand-alone speaker using the 3.5mm line-out socket, but ducks the reply to questions when using a Sonos speaker through the same line-out socket?
Did this get resolved? Is there a way to disable ducking?
No resolution yet, but annoyingly Sonos are sending out adverts saying that Alexa and Sonos now work with an adapted Play one, or any existing Sonos speaker set-up. They must think a resolution is imminent I guess?
Badge
So, I'm upstairs in the shower listening to my morning podcast and it mutes itself every 10 seconds.

Come to find out my wife was in the kitchen using Alexa to make a shopping list.

How do I turn off this muting "feature" for Alexa? Or can I assign the dot to a single room so the whole house doesn't mute everytime someone wants a knock knock joke or the weather.
So, I'm upstairs in the shower listening to my morning podcast and it mutes itself every 10 seconds.

Come to find out my wife was in the kitchen using Alexa to make a shopping list.

How do I turn off this muting "feature" for Alexa? Or can I assign the dot to a single room so the whole house doesn't mute everytime someone wants a knock knock joke or the weather.


We have an Echo on one wifi system in one house and a Dot on a different wifi system in another house. The Echo and Dot are both on the same Amazon account. The Alexa app appears to only allow me to turn on the Sonos Skill for the entire account, not selectively by Amazon device. As a consequence when someone addresses Alexa on the Echo in the house without a Sonos system, the volume on the Sonos system in the other house is decreased! It is certainly annoying, but it seems Amazon will need to allow the Sonos Skill to be selectively deployed to fix this problem. Alternatively the Echo and Dot will have to be able to be associated with a specific Sonos device.
Userlevel 3
Badge
The Playbar does duck when playing a stream from another device (not the optical input). My cable TV box (SKY TV) is in a media room and the sound inputs to a Connect. When I watch broadcasts from that cable box and stream the audio on my 5.1 setup in my living room, the Playbar (and connected Play:1s and Sub) do Duck when an Echo device receives a command. Just pointing this out since there are some posts here that imply the Playbar does not Duck at all. It does (in my installation at least) under certain playback conditions.

Edit: Or perhaps the Connect in my situation is ducking its output that is being streamed on the Playbar, but the result is the same.
I’ve just deleted the Sonos skill, as the API just isn’t ready. Sonos isn’t really usable if you have Alexa and multi-zones set up. Hopefully it will get fixed soon and then I can re-enable the skill. I’d rather control it the old fashioned way than put up with the ducking feature.