Alexa Multi Room - Help!

  • 9 January 2022
  • 5 replies



I have an Arc (+LS+RS) set up in my living room and have just purchased a One to go in my bedroom. 


I can’t seem to get it so I can listen to one thing in the Bedroom and something else in the Living Room as well as have the ability to listen to the same thing on both. 


Every time I try and listen to the same thing in both rooms it only plays in one room. 


Best answer by Ken_Griffiths 9 January 2022, 14:10

View original

5 replies

See this link to get you started:

Setup your ‘enabling’ Alexa device(s) (Sonos speakers/echo devices) in the first section of the Amazon Alexa Group and then also add your chosen Sonos speakers that you wish the ’enabling’ device(s) to control in the third section of the Group.

If you select more than one speaker in the third section of the group, then they will automatically group together for playback purposes. You also now have the option whether to include the group name in your Alexa instruction, or not.

See example screenshot of an Alexa Group attached.

*Note: when using Alexa for playback purposes, only one stream per MSP is allowed, but you can playback from different user accounts or MSP’s. Also note that multiple streams are allowed for some services via the Sonos App.



I have tried this but it’s still not working :(


I have created a Group called ‘Flat’ and added in the One in the bedroom and Arc in the Living Room. 


When I ask Alexa to “Listen to …… in the Flat” it only plays on the speaker in the bedroom.  

Can you perhaps kindly post a screenshot of your Alexa ‘enabled’ group from the Amazon App. Also maybe show/check that the ‘Playback Options’ for the 2 speakers you have added to the group is set to ‘Always’.. see photo:


Okay, I have attached photos of the exact setup for each ‘Room’ as well as the combined room. 

Still unable to play music separately in each room as well as together when wanted. 


To clarify; There is a Sonos One in the Bedroom and a Sonos Arc (+RS+LS) in the Living Room. 



Note you can only use the Alexa ‘enabling/controlling’ component once only in the first section of any Alexa group. You are adding the Sonos devices to the second section of your groups for ‘ducking’ purposes.

  • Just start by creating the one group only which you may want to call ‘Flat’.
  • Add both speakers to 1st & 3rd section of the group and set the playback options to use ‘Group Name’ instead of ‘Always’

Then if you say this …

"Alexa play some music" - it will play on the device you are speaking to only

but if you say this…

“Alexa, play some music on Flat” - it will play on both your Sonos devices.