Answered

Alexa message' sorry I'm having some trouble' when setting a timer

  • 6 November 2017
  • 6 replies
  • 2064 views

Just bought the new Sonos One with built-in Alexa, all works fine a part from the timer, when I ask for a 2 minute timer, Alexa repeats this then followed by 'sorry I'm having some trouble' any ideas what the problem/solution is?
icon

Best answer by dtbain 1 November 2018, 14:42

UPDATE. I spoke too soon! Problem now solved. While the time and date were indeed set in the Sonos app, as I reported, I had NOT turned on the setting that makes the time be "set from internet".

I've now turned that on, and timers are running properly for the first time in days.

Very odd why that setting should make a difference, and why my timers did work a week ago and then stopped working, but in any event turning on that setting seems to have solved the problem.

To turn that setting on, do the following: Sonos app > more > settings > date & time settings > then set the button labelled "set time from internet".

So Piper Warrior was right after all!
View original

6 replies

Having the same problem with my Sonos One. Works great with everything else.
I have the same problem with the alarm clock 😞.
I just finished setting up my new set of Sonos Ones and im also having the same problem trying to set a timer or alarm. Im sure this will be fixed as the software is still very young. Good to know it isnt just me!
I had this problem. You have to set the time and date in the Sonos App. Then It works ! 🙂
My problem too. I've had two Sonos One speakers for about a year with everything including Alexa and timers working fine. Then, after a day without an internet connection (don't know if that is the reason), Alexa began running into problems on BOTH speakers when setting timers.

When I ask, "Alexa set 10 minute timer", she replies "10 minute timer starting now", but then repeats "Sorry I am having some trouble" and the timer doesn't start.

Sonos told me that since the timer is not a Sonos app, I should contact Amazon; Amazon told me that since the speaker is a third-party device, I should contact Sonos.

PLEASE, do anyone have any advice? (The time and date are set in the Sonos app, so that's not the problem.)
UPDATE. I spoke too soon! Problem now solved. While the time and date were indeed set in the Sonos app, as I reported, I had NOT turned on the setting that makes the time be "set from internet".

I've now turned that on, and timers are running properly for the first time in days.

Very odd why that setting should make a difference, and why my timers did work a week ago and then stopped working, but in any event turning on that setting seems to have solved the problem.

To turn that setting on, do the following: Sonos app > more > settings > date & time settings > then set the button labelled "set time from internet".

So Piper Warrior was right after all!

Reply