Question

Alexa keeps on saying Sonos One is offline


Just went through all the settings on Sonos app as well as Alexa app named my new Sonos One OFFICE in the Sonos app and group it with all my 7 other Sonos. I can play music on all Sonos through the Sonos app, I can use Alexa to play music on any speaker, EXCEPT the new Sonos One. Alexa keeps on telling that OFFICE SONOS is OFFLINE...

24 replies

I’m having the same exact issue!
I'm having the same as well. No problem using sonos app, but Alexa can't so it
I have the same issue and Sonos support isn't responding. I want say for now I'm very unsatisfied with the new Sonos One and the Alexa App
I figured it out!! I talked to Amazon and they told me that if you set up sonos on a 5g dual band router it might not work. So i disconnected from 5g on my phone, deregistered and disabled all skills, and connected to the 2.4g connection on my router. then set up the sonos one again as if i had never done it. After this, ALEXA CAN CONTROL SONOS ONE!!
Thank you for this. I can say, my internet is working on 2.4g and I did had this issue. But, since today I can finally play radio controlled by Alexa. Special music genre is still not possible.
I'm returning mine...
I've managed to have Alexa to control the speaker after may trials, but now If I tell Alexa to play music on a specific speaker (like kitchen) Alexa recognizes the command and tell to play music on kitchen but the music ended up playing on ALL my speakers! I'm tired of this...
Userlevel 6
Badge +3
Hi Fred, sorry to hear you're having trouble. If it's playing on all of your speakers, most likely they're all grouped together in the Sonos app. Voice control doesn't have grouping built in, so playing to one room will to play all of the ones grouped together through the Sonos app.
Userlevel 1
Badge
I have the same issue, i haven’t found a solution yet and the wifi setting didn’t help? Sonos, any answer??
Juan Pablo wrote:

I have the same issue, i haven’t found a solution yet and the wifi setting didn’t help? Sonos, any answer??


If your problem is Alexa saying that Sonos One is offline, what I found out (not from the poor Sonos One documentation...) is you have to go to the Alexa app and turn the Sonos one online , under settings. I hope that helps
@FredM Where in the Alexa app settings can you turn devices online? I'm not seeing that. Alexa still saying all 4 of my speakers are offline, but they definitely aren't as I can play music via the Sonos/Spotify app as normal. Been through all suggested actions on here, no change. Never had an issue setting up many Sonos/Echo/Dot devices previously. No one seems to have a valid answer for this on the whole Internet! So frustrating
I have the same issue. My Sonos app seems set up right. Music can be played on all speakers. However, when I go through to the Alexa App: Under Settings Smart Home, devices show as set up, Skills has the Sonos Skills enabled. But in the bottom of the app there are two tabs; Home and Wifi. If I click on wifi It shows your Alexa device is not connected. to play music and media your Alexa device must be online. Goto wifi setup. when you do, there are no Sonos devices listed.
I have followed most suggestion I can find; from uninstall start again reset the Sonos One, disable the Skills, disable the devices, don't use 5g wifi. I have even tried different devices for set up. And I have spoken to Sonos Support team. No Joy. Alexa can tell me a joke but not control my music. What is funny is while playing a track if I ask her to pause the music, she replies Music has to be playing first.
I am a brand loyal consumer, however am struggling to see why the simplicity of Sonos has been destroyed by Amazon. It doesn't make sense. I'm very disappointed in the quality of this release. Sonos if your listening. Give us a clue or Alexa is going back to the shop, I'm guessing along with the other Sonos Ones on this page.
kolby100 wrote:

I figured it out!! I talked to Amazon and they told me that if you set up sonos on a 5g dual band router it might not work. So i disconnected from 5g on my phone,


Did you disconnect your phone from the 5g or Turn off the 5g at the router?
Hey,

So I had this problem today, for a good 3-4 hours trying to set up new Sonos one in my office. Literally followed the guides online, just wouldn't work, everytime "Office is offline". Factory reset the device 3 times, use android phone, then apple phone, just to try different things. Even replaced my router with a 2.4Ghz one after user kolby100 warned about 5Ghz (wasn't even enabled, but figured I'd take no chances).

Finally got it sorted, appears the phone app simply wasn't working. I'd set the skills, and it would show offline. I logged into the alexa.amazon.com page, and it showed no skill setup but the device was online. So I added the skill via the online portal... and boom. Works perfectly.

No idea why the app wasn't able to update Alexa's skills, it was able to control the music, to stream to sonos, everything else worked fine, but it just wouldn't add the skill it needed to activate voice control.

Maybe that will help others.

TLDR: Try using the online portal instead of the app (it might not be updating your skills, even through it's saying it is).
Hi Steve. Good luck with getting a reply off someone from Sonos! Same issues here as you've described (and many other users). I've sort of given up for now after sending replies & diagnostics and receiving nothing back. I'm just using it as a 'posh' Play:1 at the moment. If it wasn't for the fact I needed a kitchen speaker anyway, this would've gone back days ago. Seems to point to the Sonos skill being the issue, I could be wrong though. It's in 'beta' however, so apparently it doesn't matter if we've wasted £200 on a speaker that doesn't function properly
Thanks SHutchinson. However I've just tried this again via the web login (third time this week) and Alexa is still saying every speaker is offline. But they're not as I can play music from the Sonos or Spotify apps on all of them
Userlevel 6
Badge +3
If using the web portal isn't working, I'd suggest going into the Sonos app on the mobile device, and under More hit "Voice Control" and disable the control there. Then, re-enable it and try setting up Alexa again on Sonos.

Have you tried ;giving us a call on our support line to get this all sorted out? It's usually best to work with us live.
SHutchinson wrote:

Finally got it sorted, appears the phone app simply wasn't working. I'd set the skills, and it would show offline. I logged into the alexa.amazon.com page, and it showed no skill setup but the device was online. So I added the skill via the online portal... and boom. Works perfectly.



Thanks SHutchinson - I did this and it worked - The Sonos Skill was missing from Alexa.amazon.com account. Once I added the Skill and linked it with Sonos (which happened like a workflow once I clicked enable). Alexa now seems to be able to play Radio from Tunein, turn up and down the volume, pause music (activated by the Sonos App Manually). However as Im an Apple Music Subscriber - She can't play anything.
butler11 wrote:

Thanks SHutchinson. However I've just tried this again via the web login (third time this week) and Alexa is still saying every speaker is offline. But they're not as I can play music from the Sonos or Spotify apps on all of them



Try disabling the Skill and reEnable the Skill from the website not the app. It's worth a punt.
Ryan S wrote:

If using the web portal isn't working, I'd suggest going into the Sonos app on the mobile device, and under More hit "Voice Control" and disable the control there. Then, re-enable it and try setting up Alexa again on Sonos.

Have you tried ;giving us a call on our support line to get this all sorted out? It's usually best to work with us live.



I did call your support team - you didn't have a clue!
Steve McEvoy wrote:

SHutchinson wrote:

Finally got it sorted, appears the phone app simply wasn't working. I'd set the skills, and it would show offline. I logged into the alexa.amazon.com page, and it showed no skill setup but the device was online. So I added the skill via the online portal... and boom. Works perfectly.



Thanks SHutchinson - I did this and it worked - The Sonos Skill was missing from Alexa.amazon.com account. Once I added the Skill and linked it with Sonos (which happened like a workflow once I clicked enable). Alexa now seems to be able to play Radio from Tunein, turn up and down the volume, pause music (activated by the Sonos App Manually). However as Im an Apple Music Subscriber - She can't play anything.



Glad this solved some of your issues. The apple issue I have no idea about, I assume it's functionality problem, as the Sonos can't do Spotify either yet (gets added 21st December). Believe it's some "exclusivity" with Amazon driving that, basically making the device such a hassle to use, you're forced to buy an Amazon Music subscription. It's a shame, but I'll just wait it out and use it as a glorified radio until then. If I'm not careful with my words, Alexa basically just says "Your Amazon Music account isn't setup properly"... What's also annoying is you can't change the default music options away from Amazon to Tunein for the radio, so you have to specifically include Tunein in your requests... I understand why they make technology harder to use, so they can force sales off people, but that doesn't make it ok.
I had the same issues and it was driving me insane.

After a call with the support team at Sonos we went through all of the above but actually found out the issue was a setting on my amazon account

He said I would need a computer to access certain settings but you can do this on an iPhone by requesting a desktop version of the site.

Once you do that go to settings, content and devices and check all is ok there and you can see your devices. Then click settings then see the country settings section. My has the country as “unknown”

So for me the issue was that I didn’t set a country! Once I set that then asked Alexa to play the radio it did! And through the Alexa app my Sonos turned from offline to online.

All sorted! Hope that helps
I set up my Sonos and Alexa with the room named as Bathroom everything worjked great until I changed the room name to Bedroom (bath is in bedroom). Changed it on Sonos and Alexa app but my sonos kept saying it was offline. Seems my sonos is still registered as Bathroom on my amazon account... couldn't work out how to change this so just renamed it back to Bathroom on Sonos and and Alexa and hey presto, working fine again!
Userlevel 3
Badge +3
Splitforit wrote:

I set up my Sonos and Alexa with the room named as Bathroom everything worjked great until I changed the room name to Bedroom (bath is in bedroom). Changed it on Sonos and Alexa app but my sonos kept saying it was offline. Seems my sonos is still registered as Bathroom on my amazon account... couldn't work out how to change this so just renamed it back to Bathroom on Sonos and and Alexa and hey presto, working fine again!



If you change the name of an Alexa Device, you will at least need to select Alexa App>Smart Home>Devices>Discover. As long as you haven't set-up any Routines within the Alexa App, the best approach is to open the Alexa App on a PC via https://alexa.amazon.co.uk or .com and select Smart Home>Devices and then scroll to the bottom of the list and select 'Forget All' followed by 'Discover'. Your renamed device should now work as normal.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)